Announcement

Collapse
No announcement yet.

Blinding lights in my project. Help plz.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Blinding lights in my project. Help plz.


    Hello. I have a problem with lighting that is imported from project. In edit mode I have everything set so that the colors are good. However, in game mode, when I press play, the lighting brightens the image and blinds strongly. How can I reduce this effect? Regards below adds screens
    Attached Files
    Last edited by Dubcherry; 03-26-2020, 07:31 AM.

    #2
    Originally posted by Dubcherry View Post
    Hello. I have a problem with lighting that is imported from project. In edit mode I have everything set so that the colors are good. However, in game mode, when I press play, the lighting brightens the image and blinds strongly. How can I reduce this effect? Regards {"data-align":"none","data-size":"large","data-attachmentid":1736805}below adds screens
    {"data-align":"none","data-size":"large","data-attachmentid":1736806}
    But what light setup are you using?

    Comment


      #3
      Click image for larger version

Name:	blinding.jpg
Views:	36
Size:	334.6 KB
ID:	1737229
      I have disabled post process volume and height fog. Now you can see more clearly how the sun creates a dazzle effect. Where can I weaken this effect?

      Comment


        #4
        It appears to be auto exposure brightening, but could be something else or an additional problem(s). More info needed for inquiry.

        Comment


          #5


          Thank you for the answer and suggestion but auto exposure brightening is not a problem




          Sky light is not a problem.
          Sky sphere to.I disabled post process volume and height fog and the effect remains ... Any other ideas?




          Last edited by Dubcherry; 03-26-2020, 05:52 PM.

          Comment


            #6
            Is it using Global Illumination? what are those settings at in the World Settings? Do the materials have Diffuse Boost turned up?

            Comment


              #7
              Yes. There is global ilumination. In world setings, diffuse boost is at "1". I switched off and it didn't help either. In general, I removed everything related to lighting and a ray of light directed into the face and remains so The only thing I left is sky sphere. Could there be a reason there?
              I think it's the only way out. I paste the screen with the settings. Thank you again for all the help, because my patience is running out


              Click image for larger version

Name:	image_187130.jpg
Views:	17
Size:	529.5 KB
ID:	1738242Click image for larger version

Name:	image_187131.jpg
Views:	16
Size:	565.8 KB
ID:	1738243Click image for larger version

Name:	sun.jpg
Views:	13
Size:	551.5 KB
ID:	1738245
              Last edited by Dubcherry; 03-28-2020, 01:12 PM.

              Comment


                #8
                It may be the Light Propagation Volume. Sky sphere could do it, especially if World Settings Lightmass has high number of bounces and high intensity settings. Or, a combination of the settings for the sky sphere / skylight, and the global illumination. Try going to the Show drop-down in viewport, and disabling each Lighting method one at a time. If the extreme brightness doesn't disappear or go back to normal, then try isolating each Lighting method (skylight, global illumination, directional, etc) one at a time. So it would be turning off all but one for each lighting. This is for narrowing it down to which lighting is at the heart of the problem.

                Comment

                Working...
                X