Announcement

Collapse
No announcement yet.

Skin with Subsurface Profile has flickering edges (works fine in 4.22, but broken in 4.24)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Skin with Subsurface Profile has flickering edges (works fine in 4.22, but broken in 4.24)

    Hello. I've recently switched from 4.22 to 4.24, and now I have a problem with skin shaders using subsurface profile. Basically the edges of the model have small squares randomly appearing on them It is quite hard to catch the issue on a screenshot, so I've made a video showing the issue on my model.

    https://drive.google.com/open?id=1sm...08NphxL5MHV07m

    After a lot of time trying to fix it in the materials and lighting and project settings, I've went to see if they have the same problem in Paragon assets. And they do. This is a video I made using a new clean project with only Shinbi asset in.

    https://drive.google.com/open?id=1G9...WK_ubSnX3qSRiT

    And another new clean project using 4.22 instead of 4.24. Notice that there are no issues and everything is working as intended.

    https://drive.google.com/open?id=122...fpedQRnCAP3ZSM

    Does anyone have any suggestions on how can I fix this? The issue might not seem like a big deal, but sometimes it is very noticeable and significantly degrades the overall visual presentation.

    Thanks.

    #2
    Originally posted by unit187 View Post
    Hello. I've recently switched from 4.22 to 4.24, and now I have a problem with skin shaders using subsurface profile. Basically the edges of the model have small squares randomly appearing on them It is quite hard to catch the issue on a screenshot, so I've made a video showing the issue on my model.

    https://drive.google.com/open?id=1sm...08NphxL5MHV07m

    After a lot of time trying to fix it in the materials and lighting and project settings, I've went to see if they have the same problem in Paragon assets. And they do. This is a video I made using a new clean project with only Shinbi asset in.

    https://drive.google.com/open?id=1G9...WK_ubSnX3qSRiT

    And another new clean project using 4.22 instead of 4.24. Notice that there are no issues and everything is working as intended.

    https://drive.google.com/open?id=122...fpedQRnCAP3ZSM

    Does anyone have any suggestions on how can I fix this? The issue might not seem like a big deal, but sometimes it is very noticeable and significantly degrades the overall visual presentation.

    Thanks.
    Its the new burley subsurface scattering im guessing, find a way to get rid of that, instead going for legacy SSS.

    Comment


      #3
      Originally posted by Bits360 View Post

      Its the new burley subsurface scattering im guessing, find a way to get rid of that, instead going for legacy SSS.
      I've looked into the Subsurface Profile asset. The "Enable Burley" option is turned off. I tried turning it on and also messed a bit with all the available settings, nothing really helps.

      Comment


        #4
        Originally posted by unit187 View Post

        I've looked into the Subsurface Profile asset. The "Enable Burley" option is turned off. I tried turning it on and also messed a bit with all the available settings, nothing really helps.
        Then, im lost, i wish you luck.

        Comment


          #5
          Alright, someone on Reddit helped me with this. Going to post here in case anyone else faces the same issue.

          To fix the issue I've adjusted the config, adding the following lines to Config/DefaultEngine.ini

          [SystemSettings]

          r.SSS.Checkerboard=1

          Comment

          Working...
          X