Announcement

Collapse
No announcement yet.

Rendering different in game and edit mode

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Rendering different in game and edit mode

    when i enter game mode the effect of reflection spheres dissapear. I also feel that the overal quality of materials and lighting is also affected (not sure about that though).
    In the attached pictures the reflection difference is very obvious.

    Attached Files

    #2
    If you press 'G' in the viewport, do you see the same difference?

    If so, you've disabled specular or the reflection environment in the viewport. You could go through the options in the Show tab to find it, or hit "Reset Viewport" which will enable everything and put you back in editor mode. You can press 'G' again to make sure it changed back.
    Lighting Artist @ Rockstar Games
    ArtStation
    Twitter

    Comment


      #3
      no that wont do anything, it has something to do with the setting provided from the arcvhiz category (Im using 4.24 version) , since i migrated my project to a conventional first person game category and the absence of reflections in that case appear both in game and edit modes .

      Comment


        #4
        Originally posted by Ethylenium View Post
        no that wont do anything, it has something to do with the setting provided from the arcvhiz category (Im using 4.24 version) , since i migrated my project to a conventional first person game category and the absence of reflections in that case appear both in game and edit modes .
        That shouldnt occur. Also, use box reflections in square/rectangle rooms. It will look less distorted and thats the reason for it to exist.

        Comment


          #5
          Thanks for the tip Bits360 , i will try to use that from now on. I found a solution to my problem i dont know if its the correct way to do so though... what i did is i set r.environmentreflection to a value of 1 during game mode. I did that before btw but nothing happened , but after i rebuild my lighting it worked. The difference between the two lighting builds its that at the first one i replaced all of my meshes with a simple white material, and in the second build i left all of the original materials untouched.

          Comment


            #6
            Originally posted by Ethylenium View Post
            Thanks for the tip Bits360 , i will try to use that from now on. I found a solution to my problem i dont know if its the correct way to do so though... what i did is i set r.environmentreflection to a value of 1 during game mode. I did that before btw but nothing happened , but after i rebuild my lighting it worked. The difference between the two lighting builds its that at the first one i replaced all of my meshes with a simple white material, and in the second build i left all of the original materials untouched.
            Btw, still usually use sphere captures, but in this one single case, you want to use a box.

            Comment

            Working...
            X