Announcement

Collapse
No announcement yet.

Epic's GPUlightmass

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Originally posted by maxbrown View Post
    tc22 some things I would try to improve quality;
    - use 3d geometry you modeled yourself with proper lightmaps in 3dsMax/Maya/Blender
    - using higher lightmap sizes
    - disabling lightmapp compression in the world settings
    Thank you Maxbrown!

    i rebuild devrendering again , it seem less noise in viewport!
    and add denoise gi option! see attachment!

    seem in shadow there still had movement noise , i don't know why it happen !
    Attached Files
    Tcimage3d Studio
    Unreal Artist & Developer in archi & interior Visual
    Real Estate VR Tutor: http://tcimage3d.wixsite.com/3dvr

    Request a quote today:tcimage3d@gmail.com
    Follow us on Facebook: https://www.facebook.com/TCimage/

    Comment


      #32
      Note that when you enable ray tracing, realtime ray traced shadows will be on automatically. You probably want to set r.RayTracing.ForceAllRayTracingEffects=0 to disable all realtime ray tracing effects.

      Comment


        #33
        great work Luoshuang (and the rest of the team), really looking forward to this once it's released

        also it's great that you're reacting to feedback on this thread. so a couple of questions from me:
        1. will this work on non-RTX cards?
        2. any chance the whole thing could work at runtime? thinking of a scenario like building a procedural level and then building static lights, all under a loading screen
        Follow me on Twitter!
        Developer of Elium - Prison Escape
        Local Image-Based Lighting for UE4

        Comment


          #34
          @Luoshuang
          shader compiler is incredibly slow. is it normal or just for me? also visual studio compile takes 3.5 hour(other branchs max takes 1 hour) lol thats need patience work definitely.

          rests incredible. denoiser working good. thx for you and your team works.

          i will share the results of denoiser with single material.

          Last edited by Nocturness; 03-21-2020, 01:04 PM.
          Amberify Asset Pack | UE4.18 / 4.24
          Neonfiy Asset Pack | UE4.18 / 4.24
          Kinetica Asset Pack | UE4.23 / 4.24

          Comment


            #35

            I beg for help! I have been trying to build ue4 dev-render for a month now. I just can’t solve this problem - the engine has assembled with errors and does not start. can someone know how to solve this? I will be very grateful for any help! Click image for larger version

Name:	1.jpg
Views:	1492
Size:	210.1 KB
ID:	1740111[/SPOILER]

            Comment


              #36
              Originally posted by KoTbonda View Post
              I beg for help! I have been trying to build ue4 dev-render for a month now. I just can’t solve this problem - the engine has assembled with errors and does not start. can someone know how to solve this? I will be very grateful for any help! Click image for larger version  Name:	1.jpg Views:	0 Size:	210.1 KB ID:	1740111[/SPOILER]
              Yes, I also faced the same problem in VS2017, decided to use VS2019 (no errors, no warning)

              Comment


                #37
                Luoshuang It's just a small thing but you could rename "ToggleLightMapPreview" to "r.GPULightmass.ToggleLightMapPreview". Would be nice to have all the relevant commands in one place.
                ArtStation - Portfolio

                Comment


                  #38
                  Originally posted by The_Distiller View Post
                  Luoshuang It's just a small thing but you could rename "ToggleLightMapPreview" to "r.GPULightmass.ToggleLightMapPreview". Would be nice to have all the relevant commands in one place.
                  Well that's because ToggleLightmapPreview belongs to FStaticLightingSystemInterface - an interface allowing ppl to implement their own lightmap baking system beyond GPULightmass

                  Comment


                    #39
                    I see. Thanks for clarifying!
                    ArtStation - Portfolio

                    Comment


                      #40
                      Hi,
                      ineed help.
                      I played last week with dev-rendering build and gpulightmass, worked fine. Now I downloaded the latest one, and it is not working anymore. By "ToggleLightmapPreview" Command I got this error:

                      Click image for larger version

Name:	gpulmerror.jpg
Views:	1348
Size:	21.5 KB
ID:	1742488

                      Sorry for my bad Englich

                      Thanks

                      Comment


                        #41
                        Is there a bug in dev-rendering as of Apr 20 2020?
                        Movable objects are not lit by volumetric lightmap after the interactive lightmap building completes. Prior to completion, VLM is applied normally. The VLM samples are preserved and can be visualized. Just movable objects are no longer VLM lit after lightmass finishes.

                        Comment


                          #42
                          What is the targeted release for this? 4.26?

                          Comment


                            #43
                            Tested todays code (updated from github 200430). Build works nicely. Some scenes make UE crash though. Error message: GPU crashed or D3D Device Removed. Using a gtx1080 and driver 26.21.14.4219. Anyone else noticed this error / suggestions?

                            Also, after some testing I noticed my shadows don't look sharp anymore. Its almost looking like everything has low lightmap values (but they dont). Again, suggestions?
                            Last edited by maxbrown; 04-30-2020, 07:29 AM.

                            Comment


                              #44
                              Hi,

                              I trying to test the multi GPU function in the editor. Enabled it in consolevariable.ini, but I don't know how I write the command line parameter "-MaxGPUCount=" if I have 4 GPUs.
                              Can anyone help me?

                              Comment


                                #45
                                What's the best way to update the dev-rendering ? Do I have to install it from scratch or is there a quicker way to update it?

                                I think I'm experiencing a bug because at the moment I am getting weird colours on my mesh. I posted the problem here:

                                https://forums.unrealengine.com/deve...s-in-lightmaps

                                Do you guys know why is that happening?

                                Cheers!
                                Last edited by giuseppebufalo; 07-11-2020, 06:09 AM.

                                Comment

                                Working...
                                X