No announcement yet.

Enable CustomDepth Rendering directly on Grass / Mesh / Tutorial?

  • Filter
  • Time
  • Show
Clear All
new posts

    Enable CustomDepth Rendering directly on Grass / Mesh / Tutorial?

    Hello everyone!

    I started to follow this tutorial on post process to do cell-shading post-process:

    The tutorial works fine, but I have some troubles to use Custom Depth on every part of my scene I want.
    So basicaly as many other post-process tutorial, I use the SceneTexture:CustomDepth to be able to select the objects I want to have the cellshading post-process.

    My problem now is this one: It seems I can only found the "Render CustomDepth Pass" boolean only on some component of Actor or Blueprint.
    Thus, when for exemple I use a Landscape Grass Type (, I'm forced to specify a Mesh (impossible to input actor or blueprint), but I found no way to set a "Render CustomDepth Pass" option directly on the Mesh or the Material'.
    That means that the "Landscape Grass Type" I then set in the texture material used by my landscape texture will be using the landscape grass type, spawning around the camera some grass but with no post-process applied, and I found no way to make it so that it applies to the whole mesh so that Landscape Grass Type will have the post-process on.

    Thank you,
    I hope I'm clear enough