Announcement

Collapse
No announcement yet.

Different type of Trails / Ghosting to characters - ONLY when rendered?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Different type of Trails / Ghosting to characters - ONLY when rendered?

    Hi, I have read many posts regarding ghosting to outside of characters, but I have weird trails inside / on my characters. (see screenshot)
    This is not for game but film, so my characters are alembic and trying to reach highest quality possible for rendering with sequencer.

    The weird thing is they look fine in the viewpoint but not when rendered?
    I am using TemporalAA as the other options look terrible, but the ghosting is not there with FXAA, But i need to use TAA

    I have tried so many things, Deferred, Forward rendering, Motionblur off, DOF off in my Post processing volume.
    I tried a screen percentage of 200% but it looked way worse, all pixelated

    I am rendering at 4k


    I also tried a few commands using the Tilda key ( which I had no experience with)
    r.TemporalAASamples 4

    r.PostProcessAAQuality 6
    and a few others, but they dont seem to do much?

    Silly question, but do I need to add these to all levels / scenes, and will Unreal remember these commands when restarting?
    Is there anyway to show what commands you have set?

    It would be a lot easier if I saw updates to alias settings, commands etc appear in the viewport but I have to render a section every time to see the changes!

    Thanks for any help, I'm fairly new to unreal but so confused now

    Click image for larger version

Name:	Ghosting_01.jpg
Views:	359
Size:	52.0 KB
ID:	1714015

    #2
    That is pretty classic TAA ghosting.

    There are some things you can tweak to reduce this. I have found "r.PostProcessAAQuality=5" will reduce it.

    The settings you want to tweak are these ones, the values you pick will differ greatly depending on how much movement / speed of movement you are doing in the scene.

    r.MotionBlur.Max=0 ;disables motion blur
    r.MotionBlurQuality=0 ;disables motion blur
    r.TemporalAASamples=2 ;minimizes jittered positions and flickering, setting it higher will improve TAA quality but cause sincere flickering
    r.TemporalAACurrentFrameWeight=0.2 ;helps preventing TAA ghosting, faster visual responsiveness

    and last but not least, if you add some sharpening it will reduce it. (values between 0.7-1 should be good)
    r.Tonemapper.Sharpen=1


    Play around with specifically the framewight command.
    Unfortunately, i think you will pretty much always see ghosting in TAA.


    Here is some further reading for you if you find you cannot get the results you want, most of this is quite old, some of it not relevant any more... (adding here more or less for reference...)
    https://forums.unrealengine.com/deve...-aa-sharpening (really old)
    https://forums.unrealengine.com/deve...on-to-ghosting
    https://forums.unrealengine.com/deve...motion-quality
    Outer Planet Studios
    http://outerplanet.webflow.io/

    Comment


      #3
      Can i actually recommend that first, you try disable AA completely and see if its gone.
      I just you re-read your post. If this is for film perhaps the best approach is do disable AA, and just set your screenpercentage to 2-4 hundred

      r.DefaultFeature.AntiAliasing=0
      Outer Planet Studios
      http://outerplanet.webflow.io/

      Comment


        #4
        Hi gozu thanks so much for your help and time, that's really appreciated.

        I tried some of those commands but they seem to have no affect at all, I'm not sure they are doing anything.
        I'm hitting the tilda key.. pasting in the command and hitting Enter, that's correct right?

        even this did nothing: r.DefaultFeature.AntiAliasing=0
        Going into project settings and changing AA to none does works

        I tried rendering out a section to see the results and it was exactly the same as before?


        > Is there any feedback window showing what commands I have set? I cant see anything and after trying various things you don't know what you have tried, or how to reset?


        As I cant get any commands to have any effect the only thing that made it better was in project settings change from TemporalAA to FXAA and screen percentage to 400. But then it did crash when rendering 4k

        For some reason FXAA looks better than I remember it, maybe the commands worked on this?
        (apart from my grass, that looks bad compared to TAA)

        I do have "Temporal Upsampling" turned on in the project settings if that makes any difference?

        Thanks for the screen percentage note, I changed that in my post processing volume and it helps.

        If I do get these commands working, do they save with the project?
        Huge thanks again
        Last edited by Full Rotation; 01-29-2020, 03:05 PM.

        Comment


          #5
          No worries.

          You don't get much feedback from console in the editor. If you click play (play in editor) then you get the large black console drop down, that gives you a bit more feedback, but that is about it

          To save the commands, you can always put them into the engine config file. In the "Config" directory of your project, open DefaultEngine.ini.
          Then search for:
          [SystemSettings]

          add it if it doesn't exist. and you can just put the commands you want called on start up in there

          [SystemSettings]
          r.TemporalAACurrentFrameWeight=0.2
          r.TemporalAASamples=2
          r.Tonemapper.Sharpen=1
          r.MotionBlur.Max=0
          r.MotionBlurQuality=0
          r.DepthOfField.DepthBlur.Ammount=0

          Im unsure on "Temporal Upsampling" , i think that is when your screen percentage is less than 100 it will apply an AA filter to the upsample (big guess)
          Outer Planet Studios
          http://outerplanet.webflow.io/

          Comment


            #6
            Originally posted by Full Rotation View Post
            Hi, I have read many posts regarding ghosting to outside of characters, but I have weird trails inside / on my characters. (see screenshot)
            This is not for game but film, so my characters are alembic and trying to reach highest quality possible for rendering with sequencer.

            The weird thing is they look fine in the viewpoint but not when rendered?
            I am using TemporalAA as the other options look terrible, but the ghosting is not there with FXAA, But i need to use TAA

            I have tried so many things, Deferred, Forward rendering, Motionblur off, DOF off in my Post processing volume.
            I tried a screen percentage of 200% but it looked way worse, all pixelated

            I am rendering at 4k


            I also tried a few commands using the Tilda key ( which I had no experience with)
            r.TemporalAASamples 4

            r.PostProcessAAQuality 6
            and a few others, but they dont seem to do much?

            Silly question, but do I need to add these to all levels / scenes, and will Unreal remember these commands when restarting?
            Is there anyway to show what commands you have set?

            It would be a lot easier if I saw updates to alias settings, commands etc appear in the viewport but I have to render a section every time to see the changes!

            Thanks for any help, I'm fairly new to unreal but so confused now

            Click image for larger version

Name:	Ghosting_01.jpg
Views:	359
Size:	52.0 KB
ID:	1714015
            Leave the TAA, just turn off motionblur. Also, try these commands

            r.TemporalAASamples 4
            r.TemporalAACurrentFrameWeight 0.20

            After these 2 patches it should look better

            Comment


              #7
              Thank you both for trying to help me on this, huge apologies for not getting back to say thanks, I really appreciate your time.

              I tried some of those settings by editing the DefaultEngine.ini, but still looked bad and had issues, I can tell something is working as motion blur gets turned off, but I really cant see any improvements of changes from those other variables.

              I'm sticking with FXAA and screen percentage to 200% for now, it looks a lot better than TAA

              I'm loving Unreal as I learn, but pretty disappointed at how bad anti aliasing is, offering Temporal but it's not good.
              I see all these amazingly sharp demos and think how did they achieve that anti aliasing?

              Huge thanks again, I learnt a lot from your help!

              Comment

              Working...
              X