Announcement

Collapse
No announcement yet.

Viewport now goes dark when entering play mode

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Viewport now goes dark when entering play mode

    Working on a project in UE 4.22.3 based upon the default template with the BPSkySphere Blueprint in it. I have been using datasmith to bring assets in from 3dsmax but I usually address the UV's, materials and lights in UE. I have auto exposure turned off in project settings as well as post processing. For a time, it seems I can get everything set up and do a lightbuild on medium quality and things will come out fine. I can work in the editor and hit play mode and either way, my exposures stay the same. I'll go through some asset adjustments in 3dsmax and import assets and then at some point in UE, my scene (viewport) goes almost pitch black when going into playmode. If I create a new level and copy everything from the level where things went black, do another lightbuild, things are back to normal. Any ideas that could help?

    This issue seems to have been around for some others and no one ever seems to get it predictably resolved. People point to exposure settings but if I have no been messing with the exposure settings, I don't understand the change. Now, I will admit that I unchecked the gamemode settings box you find in the viewport viewmode>exposure>game settings. I still have not been able to figure out this setting. I know if you uncheck it, it kicks things into a different exposure and you have to make adjustments. I rechecked it but the black viewport issue remains.

    #2
    Originally posted by arcitek View Post
    Working on a project in UE 4.22.3 based upon the default template with the BPSkySphere Blueprint in it. I have been using datasmith to bring assets in from 3dsmax but I usually address the UV's, materials and lights in UE. I have auto exposure turned off in project settings as well as post processing. For a time, it seems I can get everything set up and do a lightbuild on medium quality and things will come out fine. I can work in the editor and hit play mode and either way, my exposures stay the same. I'll go through some asset adjustments in 3dsmax and import assets and then at some point in UE, my scene (viewport) goes almost pitch black when going into playmode. If I create a new level and copy everything from the level where things went black, do another lightbuild, things are back to normal. Any ideas that could help?

    This issue seems to have been around for some others and no one ever seems to get it predictably resolved. People point to exposure settings but if I have no been messing with the exposure settings, I don't understand the change. Now, I will admit that I unchecked the gamemode settings box you find in the viewport viewmode>exposure>game settings. I still have not been able to figure out this setting. I know if you uncheck it, it kicks things into a different exposure and you have to make adjustments. I rechecked it but the black viewport issue remains.
    I have experienced something like this. Many light builds, and then suddenly everything is out of whack.

    When it happens, I noticed that just restarting the editor sorted it out, but not a great solution I'll admit...

    Comment


      #3
      There's two game mode options in the viewport. One in the dropdown arrow which emulates what would happen when you played the game(hides sprites, the gizmo, and uses Post-Process Volume or camera settings). Basically, it allows you to have 2 viewport settings, so in one mode you could have dynamic shadows off for performance and the other with them still on and toggle between the two by pressing 'G'.

      The other, like you've found in exposure, works similarly except it's limited to just exposure. With it checked, it will use the exposure as set by the camera or Post-Process Volume, just like what would happen if you ran the game. With it unchecked, exposure is controlled by the viewport option only just below the checkbox.

      With either of those options set to game mode, and your viewport goes black, then you've narrowed down your issue to something in your Post-Process Volume or camera.
      Lighting Artist II @ Crystal Dynamics
      ArtStation
      Twitter

      Comment


        #4
        Originally posted by rosegoldslugs View Post

        With either of those options set to game mode, and your viewport goes black, then you've narrowed down your issue to something in your Post-Process Volume or camera.
        RoseGold, thanks for the replay. There are some good things you mention in there. I get what you are saying about the post process volume but I have scoured the settings and I cannot see what it is. I do not have exposure enabled in there at all so it makes no sense. I have already deleted my post process, rebuilt, and it does nothing to correct the dark viewport in play mode. I am increasingly becoming convinced it is a datasmith import issue. It only happens after a datasmith import but not with every import. Someone mentioned it could be exposure settings in 3dsmax at the time of export but I checked to make sure I have no exposure settings on within any of the settings. Also, the issue corrects itself as soon as I create a new level using the default template, delete all assets form the default scene and then copy the previous level assets form the previous level into the new level. Now, I import and reimport all assets I need into the older level since it is already "messed up" so to speak. I then migrate those assets to my new level to avoid any issue from datasmith importing.

        Comment


          #5
          Originally posted by ClockworkOcean View Post

          I have experienced something like this. Many light builds, and then suddenly everything is out of whack.

          When it happens, I noticed that just restarting the editor sorted it out, but not a great solution I'll admit...
          I wish mine were that simple but I can restart the editor or even load the scene on other instances of the editor in other computers and that view port is still dark until a build a new level. Thank you for the reply though!

          Comment

          Working...
          X