Announcement

Collapse
No announcement yet.

Strange blobs on meshes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Strange blobs on meshes

    Here's a picture of what I have going on:

    Click image for larger version

Name:	cube.JPG
Views:	485
Size:	56.7 KB
ID:	1707918
    This is just shape_cube from the starter content. I just made a new project ( works fine there ) and migrated the starter content into my project with the problem.

    Plonk the cube in a default new level, and when I make the skylight dynamic I see these blobs on the mesh!

    This is Mr Cube in the mesh / asset editor:

    Click image for larger version

Name:	asset.JPG
Views:	299
Size:	30.2 KB
ID:	1707919

    The point is, the blobs are appearing on A LOT of my meshes, it's really not ok :-/

    It's not the material, it's not the lightmap, it's not the cubemap yada yada yada, because (A) I didn't change any of that and (B) I have checked stuff like that while trying to find the problem.

    My feeling is that this problem is related to the following actions:

    1) I fiddled with the engine scalability settings in the editor, put the engine on medium.

    2) The engine then decides, hey I'll compile 20,000 shaders

    3) I thought, no thanks, and just closed the editor

    Now I *think* I should have let it compile those shaders and then set it back to epic. Too late now. I'm assuming some shaders, or something, somewhere in the bowels of the engine is not right.

    I removed the DDC ( derived data cache ), and yes, everything has re-compiled. Just as if I'd only just downloaded all my assets. But I STILL have this brown blob problem!

    Has anyone seen this? Does anyone know what it is? How to fix it? Etc?!

    Thanks

    #2
    Update, it only happens when the engine is set to Epic or above...

    Comment


      #3
      Kinda looks like distance field artifacts, are you using distance field ambient occlusion?

      Comment


        #4
        Originally posted by ZacD View Post
        Kinda looks like distance field artifacts, are you using distance field ambient occlusion?
        I am, and playing with those params does make the splodge look different. But would that affect the preview in the asset editor?

        Comment


          #5
          Originally posted by ZacD View Post
          Kinda looks like distance field artifacts, are you using distance field ambient occlusion?
          Yeah, so changing the distance field params in the skylight makes a difference, but doesn't fix it. I also see this problem in the material editor preview. Is MDF involved there? ( I know very little about it ).

          Comment


            #6
            HM chiming in here, not exactly like OP but very close, I get blotches of light and shadows,that at worse block shadows on ONE of my projects but I seem to be able to get rid of it if I use say ,sand texture,but my issues are terrain,not objects ,that I've noticed.

            I thought I'd checked but I'll make sure to verify DFAO .

            I've asked on answers and here and so far this is the only response even if indirect, that I've seen to date, sadly ( BUT ty! for also chiming in ).

            Just for verify on my own part,here is some of what I'm seeing on terrain at least,and its consistent on all but a few tiny pieces of terrain:

            Click image for larger version  Name:	4.23_weirdLOOKING_nodes_TerrainMat_smaller.png Views:	0 Size:	374.3 KB ID:	1708024

            OK altering /removing DFAO.....turned off ambient occlusing assuming that impacts DFAO, didnt' help, unless a restart is mandatory, system not indicating that though,anyway here is blotchiness on terrain,as abve but in vast open areas:

            Click image for larger version  Name:	Terrain_blotchy.png Views:	0 Size:	407.9 KB ID:	1708025
            Solo but Seismic - feel free to apply
            https://neighborlee1.wixsite.com/theheartseed

            Comment


              #7
              Originally posted by ZacD View Post
              Kinda looks like distance field artifacts, are you using distance field ambient occlusion?
              It seems like something's got screwed up with the way meshes are self shadowing. To fix a basic engine shape ( sphere etc ), I have to crank the self shadow bias up to 100. It doesn't even have 'generate mesh distance field' set...

              Is there somewhere to set this globally do you know?...

              Comment


                #8
                Forgot to post this, showcasing in ugly terms the problem of these 'blotches',wish I knew how to fix, but nothing works at least so far :

                Click image for larger version  Name:	Weird_shadows_overcastbyterrainBLotches.jpg Views:	0 Size:	116.9 KB ID:	1708045

                So I get this by starting to walking over terrain nearing close to shadows ,in this case,but the blotches show up everywhere, but some smaller areas.
                They even affect one of my meshes , that has in this case , burnished steel material, and instead of how that looks, its 'darkened' severely.

                I have one project working fine ,fixed it by using Sand material instead of rock_sandstone,but that's not a fix.

                Hoping for answers as this is no way to do game dev. I hope its just some setting I changed,but if so its hidden somewhere as I've gone through every component in World Outliner, and I can't find anything.
                Last edited by neighborlee; 01-13-2020, 12:08 PM.
                Solo but Seismic - feel free to apply
                https://neighborlee1.wixsite.com/theheartseed

                Comment


                  #9
                  neighborlee If we have the same problem, you can get rid of it by turning off distance fields. Have you tried?...

                  Comment


                    #10
                    Yes First thing I did on seeing this thread, if you mean turning values down to 0 on atmospheric fog ( Odd you can't just turn if OFF enirely, because occlusion combine mode has minmax only) then ya I did will turn off under project settings ( in project where I'm having troubles, can;t do atm in another project ) . I'll do so in a bit and update. Do you mean DF entirely ? I"ll check that too.
                    Solo but Seismic - feel free to apply
                    https://neighborlee1.wixsite.com/theheartseed

                    Comment


                      #11
                      Originally posted by neighborlee View Post
                      Yes First thing I did on seeing this thread, if you mean turning values down to 0 on atmospheric fog ( Odd you can't just turn if OFF enirely, because occlusion combine mode has minmax only) then ya I did will turn off under project settings ( in project where I'm having troubles, can;t do atm in another project ) . I'll do so in a bit and update. Do you mean DF entirely ? I"ll check that too.
                      Yeah, uncheck the DF option in the project settings, that fixes it for me. But... I do need them, so... :-/

                      Comment


                        #12
                        Are you both utilizing Light Propagation Volume at all? It has problems with self-shadowing and back in version 4.20 cannot be confused with Lightmass GI because it is somehow not compatible by being dynamic GI. It looks like a bad mixture of lighting techniques producing the splotches and blobs. I'm having a similar issue when I first open new projects too, and start modifying a few settings.

                        Comment


                          #13
                          Originally posted by preston42382 View Post
                          Are you both utilizing Light Propagation Volume at all? It has problems with self-shadowing and back in version 4.20 cannot be confused with Lightmass GI because it is somehow not compatible by being dynamic GI. It looks like a bad mixture of lighting techniques producing the splotches and blobs. I'm having a similar issue when I first open new projects too, and start modifying a few settings.
                          Me not, can't speak for others.

                          Notice I also get this problem with previews in the material editor !

                          Comment


                            #14
                            I checked the preview in material editor and mesh editor in 4.23.1, and both seem to bring over settings from the level I'm working in. Actually, one of the issues I'm having carried over to the mesh editor, wherein facing with camera down on the floor or at a steeper angle than say 60 degrees from horizontal results in the light becoming super bright, and at a gradual rate. At first it was at a low angle, so between 15-40 degrees in the preview of mesh editor the light was initially really bright. Background cubemap image is disabled in all this...but occurs with it enabled too. It was happening in my scene, then happened in the preview of the mesh editor. Some of the lighting data is carrying over to the preview modes of editors. Whether it's the light properties or mesh properties, or both, I don't know.

                            Comment


                              #15
                              Originally posted by preston42382 View Post
                              I checked the preview in material editor and mesh editor in 4.23.1, and both seem to bring over settings from the level I'm working in. Actually, one of the issues I'm having carried over to the mesh editor, wherein facing with camera down on the floor or at a steeper angle than say 60 degrees from horizontal results in the light becoming super bright, and at a gradual rate. At first it was at a low angle, so between 15-40 degrees in the preview of mesh editor the light was initially really bright. Background cubemap image is disabled in all this...but occurs with it enabled too. It was happening in my scene, then happened in the preview of the mesh editor. Some of the lighting data is carrying over to the preview modes of editors. Whether it's the light properties or mesh properties, or both, I don't know.
                              Interesting, I had assumed the previews were a fixed thing...

                              Comment

                              Working...
                              X