Announcement

Collapse
No announcement yet.

interior joinery gaps emitting light, but should be dark

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    interior joinery gaps emitting light, but should be dark

    Hello, learnig the ue workflow, after some search on this topic I was not able to find the answer, could anybody help me please, where I made the mistake?
    see the image.
    Click image for larger version

Name:	uelightemitinggaps.jpg
Views:	130
Size:	292.4 KB
ID:	1700509
    thanks!

    #2
    Do you have any exponential height fogs in your scene? Or sun/sky objects, hdri backdrops, that have them as child objects inside them? If so, test what happens, if you turn all exponential height fogs off, or make them invisible for render.
    It can be, that those fogs act like an area light, that lights everything, regardless of it being outside in clear daylight or inside in the darkest place possible, where no light should ever be (and ignoring all shadows and line of sights).

    Comment


      #3
      Make sure that your ceiling/walls/floor meet exactly in the corners and don't extend beyond them. Any surface that extends beyond the corners can receive light or shadow which can bleed onto the interior.

      Comment


        #4
        Hi!

        When you say planes you mean they have no thickness? ..if so, your lighting won't be realistic, this way of modelling is not suitable for Unreal, use 3d meshes everywhere!
        Any other meshes in your scene which is made out of 2d planes? ...or just not closed meshes? ...maybe those vertical panels? ...could be flipped normals too...
        Also face snapping is NEVER a good idea in Unreal if you're after realistic results...
        Also if you're after clean results turn off lightmap compression!

        Comment


          #5
          Originally posted by darthviper107 View Post
          Make sure that your ceiling/walls/floor meet exactly in the corners and don't extend beyond them. Any surface that extends beyond the corners can receive light or shadow which can bleed onto the interior.
          It´s independent from that. Even if the room is watertight sealed, as long as there is one of the fogs (usually exp. height fog, but the new atmospheric fog systems seem to work the same way) and a (moveable) sky light with it´s setting "affects world" active, you will have every corner of your interior enlightened. And in some cases, this combination can lead to such intense light errors. That setting "affect world" from the skylight sadly can enlighten even places, that have no window or opening, if there is such a fog involved too.

          Comment


            #6
            Thanks all for reply, finally the issue was light mapping. Was automatically generated by datasmith, all looked well, 1024 res, so dunno what caused that. But finally redo all uvw channels in max manually and that helped.

            Comment

            Working...
            X