Announcement

Collapse
No announcement yet.

[ISSUE]: Light bakeing issues with modular meshes?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [ISSUE]: Light bakeing issues with modular meshes?

    I'm fairly new to Unreal so I do not know if this is a common issue.
    I want to begin on a modular office, but wherever there's indirect lighting these ugly seams rear their ugly heads; see picture 1.
    It's only my modular part that this happens to. I've tried to search the internet for similar issues but nothing that help my specific problem.
    I've tried to follow tutorials to see their results and what they did to get them, but they just seem to be able to plug and play.
    The only models this seems to be an issue with are the ones I've created in 3ds max; my teacher told me it could be caused by my not models not being "Watertight" fixing that helped nothing.
    I've tried fiddling with lightmass settings but I'm quite inexperienced so I don't know if the problems there. All models have a lightmap resolution of 2048.
    Any help is wanted and appreciated even moral support.


    [Picture #1] The issue the black seams
    [Picture #2] The lightmass settings
    [Picture #3] The scene without my white walls, you can see there are no similar issues.

    #2
    Hi!

    Basically there are a couple of things that causing it:
    - your lightmap resolutions are too low
    - your lightmass settings are "random" /no idea how/where you found those settings! :S
    - your modelling is not good for Unreal because of overlapping surfaces!

    Because that was your problem/question:
    - set 0.1 - 0.15 as level scale (indirect lighting)
    - set 0.6 as smoothess and those seams will disappear!
    BUT I advice you to check lighting tutorials and read more documentation about lighting!!

    Comment


      #3
      What are the direct light settings (not indirect, and not directional, unless there's a directional light in there)? The three meshes look slightly unaligned at those seams, as can be observed by the left seam is darker than the right seam in the photo. Try re-aligning them so they're exactly lined up, not one edge is offset from another. You probably need to use grid snapping if there's difficulty with it, or object snapping.

      Comment


        #4
        The meshes are all aligned. I've solved it by turning up my lightmap resolution. now my problem is that my walls are faceting in indirect lighting.
        Btw my lightmass settings were wack and "random".
        As far as I can see there are no overlapping surfaces I've checked int the optimization visualizer and found no overlapping.

        The main problem I've struggled with for months now is the value faceting seen in picture 2.
        You can see by one of the highlights on the far wall, no faceting or seam, as soon as it's not direct lighting, there a slight change in value / harsh line, instead of a smooth gradient.

        The reason I'm doing it this way is to learn about modular environments.

        Happy holidays.
        Last edited by Lutrinae_Play_GR; 12-21-2019, 06:38 PM.

        Comment


          #5
          Hi!

          Do you mean the shape of the light hitting the far wall? ...the bright window openings?
          If so:
          - your lightmap resolution is still low! /if you'd check the lightmap density view you'd see the texel size will be equal to your "blocky" shadow shapes/
          - you have lighmap compression turned on which will always create artifacts

          If you're still talking about the shading differences between modular pieces read my first comment there is the solution!! :S

          What I meant by overlapping faces:
          Unreal doesn't like if faces are snapped to each other!! So if your walls are not CORNER snapped but they have overlapping faces where you snap 2 wall pieces together: you'll experience black lines at those sections!! Your lighmap won't align exactly with your mesh and there will be in-between texels which will try to visualize both in shadow and lit parts and will fail!

          Comment


            #6
            Sorry but, even with a modular environment you would merge the whole wall into one object. As it is you are getting 3 draw calls maybe more for those 3 panels.
            arguably you should only be getting 1.

            You can use the actor merge in the engine to achieve the correct setup.

            I would leave the corner panel on it's own.
            Usually corners are corner parts. Shaped like an < when seen from above sort of thing. Or L since walls are usually perpendicular...

            Makigirl
            So... are you saying I should completely remove the faces from areas of the mesh that are supposed to come in contact with one-another?
            So far, even if it is more expensive because of the material, I have been assigning a separate "Gap" material.
            seems to work well aside from the useless draw call. Which is useless unless you don't connect the piece.

            I guess I could just create an end cap for it, and that is a decent optimization anyway being I'm eliminating 1 material from every item. Hadn't thought about it that way at all actually....

            Comment


              #7
              You need closed 3d meshes in your scene to have the lighting work properly!
              The best solution is to remove those overlapping areas from the LIGHTMAP UVs!!

              Comment


                #8
                In Picture 2, are you referring to the vertical lines on the walls showing a difference in lighting/shadowing between?

                You're using a Lightmass Importance Volume, right? The Enviro Color is black with reduced opacity, so translucent black, and the environment color emits that color of light in all directions. It could be part of the problem with the harsh transitions in shadowing / lighting that results in those visible lines on the walls. Try changing the color to a medium grey or closer to white (or completely white), and increase opacity to 1. The number of indirect lighting bounces is rather high too. In the settings descriptions for Lightmass in the doc page, it reads that the first 2 bounces contribute most of the indirect lighting, and the remaining bounces after are free (memory and processing wise, I think) but don't add much to the lighting because light attenuates per bounce. It's similar to a flashlight aimed at a wall, where light that bounces back to light up other things far from the wall is of low visibility and brightness. I suggest trying to set Num Indirect Bounces to 3 or 4 and see what happens. It might also help to determine more of the whole problem.

                One other visualization that may be useful is Visualize &gt; Volume Lighting Samples to visualize the volumetric lightmap grid that comprises the indirect lighting. Here's a link to the Volumetric Lightmap information page, specifically to the part about settings for it in the World Settings with descriptions:

                https://docs.unrealengine.com/en-US/....html#settings

                Decreasing "Detail Cell Size" of the volumetric lightmap results in increased density of the map (more, smaller light-calculating spheres/bricks in the grid and that are near the surface geometry), which produces higher accuracy lighting / shadowing. But if the Maximum Brick Memory is at a certain level, such as too high, it can result in those spheres/bricks getting culled and lower density of the grid around geometry and away from it. The information page needs to be read carefully to understand how it works, and some tweaking / testing is definitely necessary, if you ask me.

                I think Makigirl is right about disabling compression in the lightmass settings. It'll probably yield more defined and smoothly transitioning shadow edges around the brightly lit areas on the lower part of the wall, and anywhere else. Though if it doesn't, it'd be great if you said so in the thread here. Thanks for sharing the pictures, it helps.

                Comment

                Working...
                X