Announcement

Collapse
No announcement yet.

Lightbaking makes my Szene green?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Lightbaking makes my Szene green?

    Hello,

    I have a problem with my lightbaking.
    I use a SkyLight and also a directional light to light an architectural scene. So that problem just appeared today, when I set up my directional light and use temperature to get my color.
    Also I bumped up Indirect Lighting Intensity to 2 so that I have more GI lighting.

    Now what I get is a green Ambient Occlusion. That desn't make sense to me? Why is it like that?
    On the Skylight I use an HDR for lighting. The Environment is slightly blueish to give it a more natural feel.

    I can attach a screenshot if it helps you.
    Click image for larger version  Name:	UnrealGreenLight.PNG Views:	0 Size:	579.2 KB ID:	1695883
    Last edited by TheCyberFX; 12-09-2019, 02:08 PM.

    #2
    Can't someone help me? Really getting kind of in trouble with that and don't know what to do against this. It's so annoying, when I turn up the sun it immediatly gets green in dark areas. But why? Where is my mistake?

    Click image for larger version

Name:	Unbenannt.JPG
Views:	55
Size:	334.8 KB
ID:	1696033

    Comment


      #3
      What does your HDRI look like?

      Comment


        #4
        Originally posted by ZacD View Post
        What does your HDRI look like?
        ...well you can see it on the screenshot...

        Could you RESET ALL your lighting tunes (such as intensity, fake GI multipliers... also postprocess) and build it on medium if the error still exists?
        You're trying to force the lighting with fake settings and it goes wrong somewhere... also if you've checked your reflection probes...

        Comment


          #5
          There's multiple hdri images in the screen shot. I've set people complain about green bounced lighting that ended up being grass from their hdri.

          Comment


            #6
            Originally posted by Makigirl View Post
            ...well you can see it on the screenshot...

            Could you RESET ALL your lighting tunes (such as intensity, fake GI multipliers... also postprocess) and build it on medium if the error still exists?
            You're trying to force the lighting with fake settings and it goes wrong somewhere... also if you've checked your reflection probes...
            The HDRI is a Sky, so this is blue.
            What do you mean by "Fake Settings"? Sorry, I'm still totally new to this. This is absolutely not my thing as I work in Cinema 4D most of the time.
            I will reset them all and try again. What need I to check on the reflection probes?
            Sorry for the noob questions. I will post later or tomorrow again, I try to make this look good for like 10 hours now and I want to sleep ^^
            Thank you in advance (y)

            Comment


              #7
              Originally posted by ZacD View Post
              There's multiple hdri images in the screen shot. I've set people complain about green bounced lighting that ended up being grass from their hdri.
              Sry it was on the second screenshot...
              Click image for larger version

Name:	hdri.jpg
Views:	71
Size:	69.1 KB
ID:	1696089

              Comment


                #8
                Originally posted by ZacD View Post
                There's multiple hdri images in the screen shot. I've set people complain about green bounced lighting that ended up being grass from their hdri.
                Ohh...definetaly shouldn't be the problem in this cse. The HDRI is from a sky, but without ground in that sense, so there isn't any grass. The HDR I use is the one in the second screenshot. But that's a good point ^^

                Comment


                  #9
                  Originally posted by TheCyberFX View Post

                  The HDRI is a Sky, so this is blue.
                  What do you mean by "Fake Settings"? Sorry, I'm still totally new to this. This is absolutely not my thing as I work in Cinema 4D most of the time.
                  I will reset them all and try again. What need I to check on the reflection probes?
                  Sorry for the noob questions. I will post later or tomorrow again, I try to make this look good for like 10 hours now and I want to sleep ^^
                  Thank you in advance (y)
                  Fake settings such as Indirect lighting intensity (behind your lightbuilding window) 2... well basically wherever you see the yellow arrow...
                  If I was you I would reset ALL lights and lightmass settings!! And rebuild! Maybe it will be too dark or too light or improper results BUT it's about the green tint that's coming from somewhere...
                  Yes, Unreal lighting works differently: basically you set lighting(shadow) properties as texture maps in pixels!!
                  The reflection captures: if they don't take samples from their actual surrounding (let's say you set it like 10x bigger) then they will take samples from improper places (like outside of the building!!)... so just check their proper sizes... also you have a view where you can see the whole scene as reflective, maybe you'll see the incorrect (if any) placing there...

                  No worries, we all started as beginners and we had to learn from somewhere/someone...

                  Comment


                    #10
                    Thank you very much.
                    Okay I reset all the lighting and I deleted my Postprocess Volume. I setup all the lightmaps to a resolution that is high enough but not too overkill I'd say. Also I set the sky to Scene Captured Lighting again and turned it off in the first place for testing reasons. With the standard/basic light settings in Lightmass Settings and in Directional Light Settings everything seemed to be okay - Until I try to bump up the Intensity of that light.
                    Still had that issue with the green.

                    I think I found it! I use a free preset from the marketplace for the glass material of the windows. When I delete the windows the green is gone, so it has to be something inside of the glass material, right? Gonna search for it even though I don't know if I can fix it. Otherwise I'll create my own glass material.

                    Thanks for all the information about Reflection Captures, that's quite helpful understanding this concept.
                    I started last week with Unreal, works well so far, except for that. Already got some blueprints to work but thats not the topic here ^^

                    Comment


                      #11
                      Oh cool you found it!! ...there are a couple free glass materials/tutorials!! ...there is even one in epic's automotive (?) pack!! ...not the best one but very good for a start!!
                      I think you will like it more and more!! Unreal is a VERY userfriendly software!!!

                      Comment


                        #12
                        Are you using light shafts in the directional light? If so, the Bloom Tint setting might be greenish, even if it is partly blue / red.
                        If by deleting the windows, it removes the green, perhaps those windows' glass material has green in it.
                        Color temperature is measured in Kelvins, and might be outputting a green tint...or if it's a 'warmer' temperature (usually associated with yellow / orange) it could be mixing with the blue in the HDRI. Yellow + blue is green, and if it's a bit orange would probably offset the green to the more jade-like green in the screenshot. So, if rebuilding things doesn't get rid of it, then try checking those aspects.

                        Comment

                        Working...
                        X