Announcement

Collapse
No announcement yet.

SpeedTree to UE4 issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    SpeedTree to UE4 issues

    Hi, i created a tree in speedtree and i am happy with the result. However, when i import it to UE4 it looks terrible. It looks like a blurry mess. I cant seem to find a fix. Help would be appreciated.

    You can see what i mean in the screenshots under.

    Click image for larger version

Name:	Issue1.PNG
Views:	151
Size:	298.5 KB
ID:	1690617
    Click image for larger version

Name:	Issue2.PNG
Views:	109
Size:	281.7 KB
ID:	1690618

    #2
    Hey there!

    I'm the Online Product Manager for SpeedTree so hopefully I can help. Can you post a screenshot of your export settings from the modeler?

    Comment


      #3
      Originally posted by C_Franklin View Post
      Hey there!

      I'm the Online Product Manager for SpeedTree so hopefully I can help. Can you post a screenshot of your export settings from the modeler?
      Click image for larger version

Name:	HELP3.PNG
Views:	88
Size:	26.3 KB
ID:	1692184
      Hey, here are the settings.

      Comment


        #4
        Unfortunately this is about right. The way I get around it, is making less dense leaf maps so you can see the gap's easier. I also use a distance lerp to increase/decrease the intensity of the opacity map over distance. If you divide the opacity map, it sort of works like sharpening, making the individual leaves separate better at a distance.

        You also will need to adjust the specular from 0.5 to 0.2-0.3 to get rid of the overly reflective leaves/bark.

        I also recommend adding a seperate controller and intensity slider for the subsurface and albedo levels. The default material leaves a lot to be desiered.

        Comment


          #5
          Sorry if I'm butting in, but wouldn't choosing TARGA or any non compressed format already give a better in engine result that the engine is free to mip down as needed?

          Also, it seems to me that the opacity mask material (node or layer or whatever Is used to get that opacity mask into the material) needs a multiplier altered to create more space between the leaves.
          generally speaking, if you multiply an alpha mask by less then 1 you can get the mask to slightly shrink and look more defined.


          Last thing. Dounlecheck your engine scalability settings. The floor under the tree also seems a little blurred and jagged.
          yes this could be the result of a bad screenshot, but it is worth a look since the engine can and often does scale down for performance....

          Comment


            #6
            Mipmap sharpening is a life saver, especially for whatever texture has your opacity mask, as well as the Opacity Clip strength in the material itself. It should default to 0.333, even dropping it down to 0.3 can improve sharpness. Definitely check your scalability like MostHost suggested though, since if you have any frame drops for a period of time, the editor will automatically drop scalability if you don't catch the popup. Epic is the better option while you work.

            Also I do this a lot for stills, and if you're developing a game it might not be the best option given that it can increase ghosting, but reducing the number of samples for TAA can improve sharpness. Typing "TemporalAA.Samples" in the console should bring it up and it defaults to 8 on Epic, try anything down to 2.
            Lighting Artist II @ Crystal Dynamics
            ArtStation
            Twitter

            Comment

            Working...
            X