Announcement

Collapse
No announcement yet.

Depth of Field / Transulcent Materials Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Depth of Field / Transulcent Materials Problem

    Hi Guys, after setting the depth of field in my scene I noticed that any object that is next to an object with translucent material applied (all the windows in the scene) the depth of field looks sharp and it does not blur out the same way everything else does (The metal frame decor around the windows). I tried the glass material with and without opacity but maintaining the material blend mode as translucent but the result is the same as shown in the image attached. This problem happens in the two depth of field modes I tested (BokehDOF and CircleDOF). Anybody knows the reason why this is happening and any idea on how to fix it?

    Im using Unreal 4.20.3

    Thank you all for the help!

    Fabio

    Unreal 4.20.3
    Last edited by fapelbaum; 11-05-2019, 01:10 PM.

    #2
    Need some more info here.
    Are you using a custom depth buffer and sorting transparencies?
    Are your reflections built? your lighting?
    Can you provide a sample project or details on the PP to replicate?

    Comment


      #3
      I don't have the editor up in front of me at the moment to check the actual name of the setting, but in your Material there should be an option in the details panel for something like "apply after depth of field" that will solve this for translucent materials. They aren't automatically added to scene depth meaning they won't have DOF applied.
      Tim Hobson | Learning Resources | Epic Games
      UE4 Documentation

      Comment


        #4
        Originally posted by Tim Hobson View Post
        I don't have the editor up in front of me at the moment to check the actual name of the setting, but in your Material there should be an option in the details panel for something like "apply after depth of field" that will solve this for translucent materials. They aren't automatically added to scene depth meaning they won't have DOF applied.
        Love U!!! Thank you so much!!!

        Comment


          #5
          I am having the same problem, but I can't seem to find the "apply after depth of field" setting that's mentioned here. Could someone please be a bit more specific about where this setting is?
          I'm using v4.5

          Thanks for your time!

          Comment


            #6
            Originally posted by grendel2k View Post
            I am having the same problem, but I can't seem to find the "apply after depth of field" setting that's mentioned here. Could someone please be a bit more specific about where this setting is?
            I'm using v4.5

            Thanks for your time!
            I'm having the same issue. Anyone know?

            Comment


              #7
              If anyone is interested, I've found the answer. The setting that requires unticking is now called 'Seperate Translucency'.

              Comment


                #8
                There's a different setting called "Render After DOF", which I think is supposed to be a fix for that, or to return a blurred, translucent object back to non-blurred in the case it's needed. Don't enable if all translucent objects are to be blurred.

                Comment

                Working...
                X