No announcement yet.

Lighting Glitches

  • Filter
  • Time
  • Show
Clear All
new posts

    Lighting Glitches

    Hi all,

    So i've been trying to tidy up my lightbuilds for a while, to improve their quality, iron out any problems etc. and for the most part is has been going well.

    However i keep running into some reccuring problems i'm unable to really stamp down on.

    In the first image their's a couple of issues, the first being the random black shadows in the corners. That whole face of wall is its own seperate mesh, with a pretty sizeable lightmap resolution applied to it, i've also added extra faces to the edges to help contain any weird shadows, however its not fully worked as you can see.

    Theirs the additional problem of those marked in yellow, which is just spotty shadows being baked in, sometimes its quite dense, other times it things out, and often it appears on the ceiling in just one or two locations but not others which are super sharp and lack shadows (Other than Post Process AA)

    My third is i get these weird white patches in some tiles. This isnt the only place it appears in the scene but it is the most consistent. At first i thought it might be the wall behind the tiles causing problems, but that wall is a solid black material so nothing should be coming through from that. The lightmap res is high on the item as well so its not that.

    If anyone has been struggling with these before and has a solution i'd love to hear from you and discuss

    In order to give you a more precise answer, we need more information of your model.Could you send a wireframe screenshot so I can see yout model? And also, send a screenshot with your lightmap density enabled!

    How's your lightmap resolution? For interior scenes, the light bake works better if you have your geometry properly mapped. I see that you're compressing your Lightmaps, this is not good for baking light, you should uncheck that.


      Hey Bathil sure thing, i've attached them both below, Sorry if the wireframe is a bit messy, wasn't too sure how to best get that image.

      In regards to the lightmaps, i've tried both having them incredibly high in the red (We're talking 2048 high) and what it tells me is the best at 128, but neither had any noticeable effect, so right now i've just put it to 256 for this orange shade.



        Your lightmap resolution is too low!
        Are you using just planes as walls or 3d objects with thickness?
        Are your meshes/walls corner/edge snapped or face/polygon snapped?


          I don't think it's a lightmap resolution issue, but indeed you could do as Makigirl said, try bumping up the lightmap resolution of this meshes.
          Just to make sure, open each mesh and check the 'generate lightmap UV' and then go to your World Settings and uncheck the 'Compress Lightmaps' option.
          And also, are you using GPU for baking?


            Hey guys, thanks for getting back to me.

            Yeah i had thought it was the resolution before, but after dialing it up to 2048 on all wall faces (And increasing my build times considerably!) their wasn't any noticeable difference.

            These ones are just a one sided plane, but i've also tried this with them shelled to create the extra faces without any difference. All meshes are snapped to each other. Theirs a slight overhang in the corners where the roof pokes over due to the chamfer, but its about 2mm in size.


              RED_X_Strike posted that on another discussion, and maybe can help you:
              Also worth checking to see if your Lightmap Coordinate Index (model editor window in Unreal) aligns with whatever UV Channel is for your lightmap. (NOTE: Unreal starts with 0, so UV Channel 1 in 3ds Max is 0 in Unreal - when importing an FBX, depending on if you generate lightmap coordinates or not, it will typically set the Lightmap coordinate index to the highest number with UV information).


                Yes i'm afraid it does align as well. Used Datasmith to bring the assets over so anything like that should already be taken care of.

                Suppose it might be the automatic unwrap it did, but you'd hope it would understand something so simple!

                Do you think using the GPU baking setup might have better results?


                  Yes, depending on your 3d modelling software you'll always have some unwrap issues.
                  For the GPU baking setup, are you familiar with Luoshang'sLightmassConfiguration? If so, try setting your BaseLightmass.ini:


                  This value is bumped up in order to make sure it works, but you can lower this to reduce baking time..


                    ...well GPULightmass will produce even more errors with planes as walls and 2sided material!! :S
                    With planes you won't get realistic results!!