Announcement

Collapse
No announcement yet.

Shader Complexity Masked Overdraw not visualized in 4.23

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Shader Complexity Masked Overdraw not visualized in 4.23

    I am wondering if this is a bug or working as intended. Both images are the same tree, with the same setup, the only difference being one is 4.23 and one is 4.22 engine version.

    The one that shows low shader complexity is 4.23. The other is in 4.22 and what I expect to see with masked materials, that being overdraw is clearly visualized.

    #2
    https://issues.unrealengine.com/issue/UE-81929

    Comment


      #3
      Just installed 4.24 and still not fixed.

      Comment


        #4
        Originally posted by JohnADaniels View Post
        Just installed 4.24 and still not fixed.
        Unfortunately the issue report was marked from 'unresolved' to 'non-issue'. Time to pray~

        Comment


          #5
          This problem seems to just get worse in 4.24. I am using the lastest 4.24.2. Now you have to wait a bit for the editor to rebuild some shaders every time when setting the view mode to Shader Complexity, Shader Complexity with Quads, or Quad Overdraw. The results are just like what vanlacke reported. Packaged games with debug view modes enabled would crash when enabling Shader Complexity view mode.

          Comment


            #6
            I also noticed that. It was useful to visually debug the overdraw of scenes with masked materials, now it doesn't work.

            Comment


              #7
              I think this happens when early z pass for masked materials is on.
              Which is the correct behavior - 'Masked material only in early z pass' removes overdraw completely for all passes after pre-z pass. That's how it can speed up foliage drastically.

              Comment


                #8
                Oh... So if I'm not wrong, it's because from 4.23+, the "Mask material only in early Z-pass" in project settings is set to automatic, while in 4.22 and before we had to enable that manually.

                Comment


                  #9
                  Early z pass is on, thats the real cost.

                  Comment


                    #10
                    But there is a same situation even if u disable early z -pass

                    Comment

                    Working...
                    X