Announcement

Collapse
No announcement yet.

Excluding movable objects from baked lighting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Excluding movable objects from baked lighting

    Hi,

    so I have a very strange behaviour or maybe I'm just misunderstanding the concept here. I have a level that I baked and a sublevel with an object that is set to movable.
    Now if I bake my main map with the sublevel inactive (and thus the movable object hidden), shouldn't the movable object be completely black after the bake? It even says just when I hit the bake button that all objects that are inside my sublevel will be excluded from the bake.

    For some reason, my movable object gets lit too once I load the sublevel in. But I need to separate static baked meshes completely from movable objects. Whats wrong here? I even have different light channels setup for static and movable objects.

    Hope someone can shed some light on this (pun intended). Thanks in advance!

    Cheers

    *Update*: It's the volumetric lightmap that I want to disable completely. Is there any method available to do this?
    Last edited by IceDealer; 09-28-2019, 03:33 PM.

    #2
    For anyone wondering: To completely disable Volumetric Lightmaps you have to change Volume Lighting Method in the Lightmass Settings of World Settings to "Sparse Volume Lighting Samples". Then in the Output Log, write: r.IndirectLightingCache 0

    Movable objects now shouldn't be lit by Lightmass.

    Comment

    Working...
    X