Announcement

Collapse
No announcement yet.

Problem with shadows

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Problem with shadows

    Hey guys! I'm new with unreal engine and I have a problem with the shadows on a VR model that I am creating. Do you have any tips for a beginner to fix those issues? Thanks and have a nice day!

    PS: The material in the back is white, and right now it's black because of the shadows. There is already a skylight in the project.


    #2
    Hi!

    REALLY tiny screenshot!!
    If it's static lighting: usually (always?) when polygons turn black after light build they don't have lightmap uvs assigned to them! Check your lighmap if it's overlapping or parts are outside of the given space...

    Comment


      #3
      Originally posted by Starken Wolf View Post
      Hey guys! I'm new with unreal engine and I have a problem with the shadows on a VR model that I am creating. Do you have any tips for a beginner to fix those issues? Thanks and have a nice day!

      PS: The material in the back is white, and right now it's black because of the shadows. There is already a skylight in the project.

      Hello!
      As Makigirl have said, despite the tiny screenshot, you should review your lightmaps. When importing a mesh to UE4 you have an option to Generate lighmap UV's, which will automatically create lighmaps for you. If this black stain continues you should increase the lightmap resolution (max recomendable is 1024).

      Comment


        #4
        Looking at that it doesn’t look like a light map issue.
        I would check your exported model. Looks like a flipped normal to me.

        Comment

        Working...
        X