Announcement

Collapse
No announcement yet.

SeparateTranslucency obliterates alpha for SceneCapture2D

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    SeparateTranslucency obliterates alpha for SceneCapture2D

    Scenario:

    (forward rendering, 4.23)
    Make a new level.
    Add a SceneCapture2D Actor, source = "SceneColor (HDR) in RGB, Inv Opacity in A"
    Create and assign a render target for the capture actor to use.
    Aim the SceneCapture2D at a plane mesh which uses a AlphaComposite (or Translucent) material which outputs interesting alpha.
    For clarity, use the SceneCapture2D's "Show Only Actors" list to see only the test plane.
    No need to run the game, just do:

    Disable separate translucency via cmd: "r.SeparateTranslucencyScreenPercentage 100"
    Observe render target: capture has an interesting alpha channel.

    Enable separate translucency via cmd: "r.SeparateTranslucencyScreenPercentage 50"
    Observe render target: capture has a solid alpha channel.


    https://gyazo.com/ebf7d5872a3c9f9dbaa1cf7348b2aafd

    Any insights? THANK YOU
    Last edited by mikedludlam; 09-09-2019, 02:16 PM. Reason: added engine version
    CG and CG related accessories.

    #2
    Is the translucency option in the scene capture checked?

    about the only thing I can think of.
    other options/issues would have to be unchecking the options of the scene capture 2d items one at a time.

    Also changing the render target from whatever it's at to Final Color may give different results.

    the options under that all do "something" different and some pack the Alpha differently then others, so maybe your apha is no longer visible as the Aplha channel in the current render target...

    Comment

    Working...
    X