Announcement

Collapse
No announcement yet.

Decals Always Transparent

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Decals Always Transparent

    I'm trying to add bullet holes to my game using UE 4.22.3, but no matter how I tweak the settings, they always remain partly transparent (want completely Opaque). Scaled up example:



    https://i.gyazo.com/5ec456275dde1e18...9067c2926f.png

    The material:

    https://gyazo.com/f8aed4ced7d9759d840475aa7396d004

    I've tried several solutions suggested in similar posts, including enabling DBuffer decals, setting Early Z-pass to "Opaque and masked meshes" and "Mask material only in early Z-pass" to true. I've also set the Renderer Settings in Engine.ini to:

    [/Script/Engine.RendererSettings]
    r.GPUCrashDebugging=false
    r.EarlyZPass=2
    r.EarlyZPassOnlyMaterialMasking=False
    r.EarlyZPassMovable=1
    r.DBuffer=1

    To be honest, I don't know entirely what the above accomplishes since I just found the various solutions in the forums... except they weren't solutions for me (but seemed to work for most others). Have I missed something or is there some sort of bug that prevents entirely opaque decals (apart from the alpha) in UE 4.22.3?
Working...
X