Announcement

Collapse
No announcement yet.

problem compiling shaders

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    I'm having a problem where it crashes when I apply a texture, it gives me an error something like"expecting compile worker 5, found 0 instead" and it won't compile the texture I've placed and when I click ok it crashes...

    Leave a comment:


  • replied
    up ....
    Is there really anyone to help me? The landscape starts to compile, 6800 Shaders, with each save I know he has to spontaneously compile But why 6800k ??? It's a landscape that is 15x15

    Leave a comment:


  • replied
    Originally posted by MostHost LA View Post
    That's not a bug. Its 100% normal on every first paint of a new layer on a lanscape tile that did not include the layer before.

    it's been two weeks I'm on the landscape
    it's not the first painting.
    Attached Files
    Last edited by Internautex; 08-26-2019, 03:49 PM. Reason: 17k shaders... WTF ??

    Leave a comment:


  • replied
    That's not a bug. Its 100% normal on every first paint of a new layer on a lanscape tile that did not include the layer before.

    Leave a comment:


  • replied

    and with the tesselation...
    Impossible to work

    Leave a comment:


  • replied
    Originally posted by MostHost LA View Post
    1)
    do the shaders ever finish compiling?

    2)
    Are you painting more then 4 layers on the same tile?

    3)
    I don't actually see any error in your screenshots?
    1 : the compilation finishes correctly
    2: no (Max 3)
    3: there is no problem in the code


    I have a very small Landscape , and I did not work tesselation
    Here's a video example of what's going on https://www.youtube.com/watch?v=Lrz1...ature=youtu.be
    Last edited by Internautex; 08-26-2019, 05:39 AM.

    Leave a comment:


  • replied
    1)
    do the shaders ever finish compiling?

    2)
    Are you painting more then 4 layers on the same tile?

    3)
    I don't actually see any error in your screenshots?


    As a general rule of thumb. Lanscape tiles don't like more then 12 textures or (8 textures?) On them at the same time.
    if your landscape layer is merging in as many textures, it won't actually paint unless you make sure the type of texture is changed from whatever it is now to the shared version.

    The exact name of the texture mode for this is
    Shared: Wrap
    or
    Shared: Clamped

    since I didn't care about limitations for my project I haven't throughly researched if there are any brought about by this.
    I believe i read that this will in fact it will only work with direct-x but I would take that with a grain of salt without researching it further.

    Leave a comment:


  • started a topic problem compiling shaders

    problem compiling shaders

    Hello Everybody I need Help


    i creat a landscape but i have a problem when i paint the landscape its always error and open compiling shader. i tried anything i also deleted data cash but its doesn't work.
    I have 6 Colors in this Landscape and i'm in the version ue 4.22 i send you a screen shot for understanding me betther.

Working...
X