Announcement

Collapse
No announcement yet.

Ray traced translucency breaks eye occlusion shader

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Ray traced translucency breaks eye occlusion shader

    I'm aware that real-time ray tracing is still in beta, still wanted to bring this issue to the devs attention. As the title says, ray traced translucency breaks the eye occlusion shader. IOR is also wrong. Which I found is a general problem. It'd be nice to have control over it in the material.

    Click image for larger version

Name:	eye_occlusion_broken.jpg
Views:	250
Size:	130.7 KB
ID:	1653072
    ArtStation

    #2
    @Fussybucket: Any ideas?
    ArtStation

    Comment


      #3
      Try change "Max.Refraction Rays" to seven.
      Attached Files

      Comment


        #4
        I already tried upping the Max.Refraction Rays to 8 or even higher that's not the issue.
        ArtStation

        Comment


          #5
          Dunno if you guys figured this out yet, I found that turning off "Cast Raytraced Shadows" in the master material sorted it for me.

          Comment


            #6
            Unfortunately not working, that option is actually off by default in the 4.24 version of the material.
            ArtStation

            Comment


              #7
              If you need it to work, toss it into the forward shader so it doesn't use ray tracing.

              if you are just bringing up the fact it doesn't work correctly...
              yes. It's been an issue reported numerous times on here.
              The last topic I remember on it had an issue tracker number - if you can spot it you should log in and vote on it.

              As far as end result, you would really have to look up close to notice the difference on this tiny detail between ray traced and not raytraced - were it not for the shadowing.
              And if I remember correctly, it is an issue with the shadow.
              the mesh is causing the shadow despite being translucent, causing the eye area to appear black.

              If you could just get the material not to cast any shadow you should be able to get it to work with raytracing as well. In theory, based on what I remember at least. (Despite the fact you are saying otherwise, perhaps the instance is set to use it?)

              Also, the tear duct and the eye both have a different transparent material instance. I guess it's not the eye, but an occlusion mesh on top of it that makes it glossy.
              It seems like one is working fine - I would review the settings on both.



              Comment


                #8
                That one other thread on the topic didn't have an issue tracker but I filed a bug report a couple days ago:
                https://issues.unrealengine.com/issue/UE-87521

                I already tried changing the material to opaque and forward, to no avail either. The instance is using the same settings as well.

                Since it now reported, let's hope it'll be fixed sometime in the near future.
                ArtStation

                Comment

                Working...
                X