Announcement

Collapse
No announcement yet.

Dynamic Shadow Popping

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Dynamic Shadow Popping

    Hello!
    I've been trying to resolve an issue where I'm seeing shadow "popping" between resolutions on some assets as the camera pulls out. It should be noted that I'm not particularly worried about performance.

    The light is a stationary pointlight, with these modified properties (attached, not sure how to embed image in this message)

    The prop is moveable and has no LODs (looks like lod popping at first)


    I'm a bit new to light setting, so any help much appreciated!
    Attached Files
    Last edited by GavinUnit; 08-11-2019, 10:11 PM.

    #2
    Its shadow cascade problem, it will always happen no way around it unless you bake your lights.

    Comment


      #3
      Dang... there's no way to push the cascade distance? The shadow needs to stay animated, as the light material flickers causing the shadow to flicker (a desired result)

      Comment


        #4
        Originally posted by GavinUnit View Post
        Dang... there's no way to push the cascade distance? The shadow needs to stay animated, as the light material flickers causing the shadow to flicker (a desired result)
        i was told the shadow cascade distance can not be dynamically adjusted during runtime, that is a no i suppose.

        Comment


          #5
          its not a shadow cascade problem. it's the the default per-object shadows. they cannot transition smoothly like cascades.
          Use Cascaded Shadow Maps if you want a smoother transition. or you can play around with
          r.Shadow.MinResolution
          r.Shadow.MaxResolution
          r.Shadow.FadeResolution
          r.Shadow.FadeExponent
          r.Shadow.minRadius

          Comment


            #6
            This can be fixed easily tho, if you have the performance. Put your min resolution to 1024.
            This will force the shadows to stay sharp at a1/4 level of maximum.

            Fade resolution and exponent did nothing for me and you shouldnt play around with these bc they break under lower settings.

            Comment


              #7
              Hmm, I tried sticking
              r.Shadow.MinResolution=1024

              and also
              r.Shadow.MinResolution=2048
              r.Shadow.MaxResolution=2048

              into my defaultEngine.ini , also just in the editor prompt (also tried sticking them in defaultEditor and defaultGame... because I'm flailing around wildly), but they don't seem to make any difference. Am I doing something dumb?


              Thanks again for the help!
              Last edited by GavinUnit; 08-15-2019, 11:08 AM.

              Comment

              Working...
              X