Announcement

Collapse
No announcement yet.

static skylight not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    static skylight not working

    Hi,
    i have problem with static skylight it seems not working my scene just dark and some times it's working with me great but i dont know why this scene like this.


    Click image for larger version

Name:	Capture.JPG
Views:	2656
Size:	244.0 KB
ID:	1650634

    * note : 1. any mobility for skylight works fine except static and i want static to get more realistic looking .
    2. i have movable objects like doors its so bright not like any object like this "it was brighter than this".


    Click image for larger version

Name:	Capture02.JPG
Views:	2639
Size:	134.5 KB
ID:	1650636




    Attached Files

    #2
    1. Are you sure your Static SkyLight isn't working? It won't give you any specular, which when toggling between static mobility and the others, is the primary difference. One isn't more realistic than the other.

    2. You need to increase the Volumetric Lightmap Density around that area, or bake the door "as if static" if that's an option for you.
    Lighting Artist @ Rockstar Games
    ArtStation
    Twitter

    Comment


      #3
      Hi!

      You have compressed lightmaps turned on which causing all the pixelated "dirt"... also higher lightmaps wouldn't hurt if you're after realistic look...
      I think you can still go lower with exposure to get a brighter scene...

      Comment


        #4
        Originally posted by rosegoldslugs View Post
        1. Are you sure your Static SkyLight isn't working? It won't give you any specular, which when toggling between static mobility and the others, is the primary difference. One isn't more realistic than the other.

        2. You need to increase the Volumetric Lightmap Density around that area, or bake the door "as if static" if that's an option for you.
        thanks man for your replay , when you mention "Volumetric Lightmap Density" you mean to put in my scene "VolumetricLightmapDensityVolume" instead using "LightmassImportanceVolume"because usually i use only "LightmassImportanceVolume".

        and can i use both or only one because i did this but same result

        Comment


          #5
          Originally posted by Makigirl View Post
          Hi!

          You have compressed lightmaps turned on which causing all the pixelated "dirt"... also higher lightmaps wouldn't hurt if you're after realistic look...
          I think you can still go lower with exposure to get a brighter scene...
          thank you about compressed lightmaps its more clean now , but about lower exposure i go to exposure when i increase the "exposure compensation" bloom out from the window go crazy
          Click image for larger version  Name:	Home_S_Home--Unreal-Editor-8_18_2019-3_47_54-PM.jpg Views:	1 Size:	349.0 KB ID:	1654301
          Attached Files

          Comment


            #6
            Well this is how it goes! You'll have to find a balance!! ...your directional light is too bright...
            ...usually what I do is to set exposure to a fix min-max and then the lighting /exposure/ won't be changing, so you can examine/set your lighting better...
            ...the density setting is under lightmass!

            Comment

            Working...
            X