Announcement

Collapse
No announcement yet.

Best practice: Temporal AA jitter free?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Hmm, I have no idea. Have you tried forward rendering and MSAA? I am just very curious what is causing such glitching visual artefacts, been working on different projects with UE4 for a very long time and never had this problem.

    Another thing to try is (just for a test) turn off the shadows of the lights.

    Edit: Also try to turn off motion blur in postprocess settings.
    Last edited by NasteX; 08-12-2019, 03:02 AM.

    Comment


      #17
      I tried MSAA, but haven't been able to get results as smooth as TAA with it, so that still seems to be the best option. Turning off shadows and motion blur also doesn't seem to fix it.

      "I am just very curious what is causing such glitching visual artefacts" SAME!! It just seems to be a bit too obvious to be a bug - I must be doing something wrong!

      I've uploaded the mockup project in which I recreated the artifacts here, if you are keen to have a look:
      https://www.dropbox.com/s/0b4ap4wfn7...E_Lab.zip?dl=0
      It's a really simple setup. Ran it on two different machines, both create the same jitter noise.

      Comment


        #18
        Alright it was def AA problem so what actually is happening is that you render in low resolution and because of that there is not enough pixels on the screen so you get "glitching" and its so visual because of your strong specular highlights. This is just the basic of basics of explanation.

        Just raise the Screen Percentage inside PP to 400 and render out a .png sequence with Level sequencer.

        I uploaded a updated version with a Cine Camera and Level Sequencer for you to see the setup - Uploading now, check for link later today. - Link: https://drive.google.com/file/d/1xav...ew?usp=sharing

        You can find my .png that I rendered out for the test inside the Saved > Video Capture folder.

        I hope this fixes your problem. The mystery is over.

        Edit: I deleted the .png sequence, the total size was too big.
        Last edited by NasteX; 08-12-2019, 07:43 AM.

        Comment


          #19
          Yay! At least I don't need to change the topic of this thread, haha. THANKS NasteX!
          It does make sense, as it also seems to be more obvious on smaller objects.

          I actually rarely had this problem when exporting a sequence from the level sequencer, only recognized it at runtime.
          Is there any way to fix this during runtime, as screen percentage on 400 is a beast performance-wise. Still runs fine on 200, but thats about it.

          Comment


            #20
            On closer inspection I noticed the same you did that when the coin is "still" its not exactly still, but moves really slow and its the thing the causes the jittering. I suggest you to add all the coins that are spawned inside an array and after a few sec delay to turn off simulate physics on the coins that are asleep (check sleep/awake workflow) or just the ones that stop move. So they wont move or do anything physics related. Ofcourse this will lead to other problems that the coins hit by new coins wont move, but in my opinion its a small compromise to do.

            Comment


              #21
              Thanks for the suggestion re sleep/awake workflow! Makes a lot of sense to me.
              Will look into it and keep you posted!

              Comment


                #22
                Alright. I can pretty much confirm now that the glitch is caused by slow moving physics objects. If I disable physics the moment the object drops under a certain value for linear and angular velocity, I can get rid of the error almost completely. Therefore I assume that this is what is causing the issue.

                Unfortunately I do kind of want to avoid loosing physics completely as the whole thing depends on it, so my best workaround at the moment is to turn physics off and on again immediately, virtually stopping the object but still have it be responsive in case it gets hit by other actors. Not ideal, as it still introduces a good amount of glitchiness, but the best I could find for the moment.

                Comment

                Working...
                X