Announcement

Collapse
No announcement yet.

softer shadows

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    softer shadows

    Hi All,

    I am refining my workflow from 3ds max, substance painter to UE4. I am working on my lighting inside UE4. I am having some issues with the shadows. I want nice soft contact shadows. Right now the shadows from the sun are still a little to sharp. I set the indirect lighting intensity to 2.0 which in the view port sets the shadows to a nice soft look. But when I bake it its not soft.

    Not sure what controls the shadow softness on the Spotlights?

    Any help would be appreciated.

    Thanks
    Alex



    Attached Files

    #2
    When you change the Indirect Intensity, it invalidates baked lighting and the Directional Light switches to dynamic shadows until you rebake. If you're sticking with baked shadows, you can increase the Light Source Angle/Source Angle to soften shadows. If it's Stationary, you can hit the "Use Area Shadows" checkbox. Or, use dynamic shadows with Cascaded Shadow Maps by increasing the draw distance for them in the light properties if it's Stationary.
    Lighting Artist II @ Crystal Dynamics
    Former Lighting Artist @ Obsidian Entertainment
    ArtStation

    Comment


      #3
      Adjust the light source angle under the lightmass settings. That changes the effect to make the directional light more like an area light to where the further away the shadow is the softer it gets.

      Comment


        #4
        Thanks guys! Worked like a charm. Check out the updated images.

        I do have a another unrelated question. Check out the screen grab lighting only. What do you think is going on with my ceiling plane? Unwrapping issues?

        Attached Files

        Comment

        Working...
        X