Announcement

Collapse
No announcement yet.

UE4.22.2 RayTraced Global Illumination not working but reflections are...?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UE4.22.2 RayTraced Global Illumination not working but reflections are...?

    Hi all,

    I created a new project in 4.22.2 for Ray Tracing. I enabled the DirectX 12 as the default RHI, turned on RayTracing and SkinCache.
    After creating a test box scene the reflections are working with RayTracing but the global illumination and ambient occlusion are not.

    Click image for larger version  Name:	ue4raytracingnogi.png Views:	1 Size:	562.3 KB ID:	1624973 This pic shows my scene but the shadows are completely black.

    The scene:

    - Allow static lighting is disabled in the project (it didn't have any RTGI before I disabled this either)
    - There is one Rectangle Light at the top with Cast RayTraced shadows enabled
    - A PostProcessVolume has been added and the RTGI Enabled setting is ON.
    - I have enabled the r.raytracing.globalillumination and r.raytracing.ambientocclusion

    I've checked that Windows 10 is version 1809
    The Geforce NVidia driver is version 430.86

    My Graphics card is a 1080ti so not full RTX but using the nvidia driver upgrade feature

    I've tried searching for a solution and tried a few within the project but I cannot get it to work.

    Any ideas would be appreciated.

    Thank you.
    Last edited by 3dev; 05-28-2019, 09:17 AM.

    #2
    I'm not sure if those reflections are raytraced, might be screenspace only. In your Post Process Volume, switch Reflection Type from Raster to Ray Tracing and watch for a difference. If it is the same, raytracing is not working. Your 1080ti should be fine. Check your light, it should have "Cast Raytraced Shadow" enabled. For raytraced ambient occlusion you need an ambient cubemap plugged into your Post Process Volume.

    Comment


      #3
      Ok, after some testing...

      The problem seemed to be with the Sky Light having a sample range that created a cubemap that was outside of the brush box I was using. By decreasing the range to 200 (cm's) or 180 the scene started to be lit but was still dark. Increasing the intensity scale to 5 or 10 helped a lot.

      Click image for larger version

Name:	ue4raytracinggriderror.jpg
Views:	102
Size:	115.6 KB
ID:	1625838

      The next problem was this grid but this sort of error has to be accepted for now as the ray tracing is all very new in UE

      I turned on the Sky Lights "Cast RayTraced Shadow" but it was very noisy :/

      Click image for larger version

Name:	ue4raytracingnoise.jpg
Views:	100
Size:	277.7 KB
ID:	1625839

      ...again this is to be accepted

      Overall I'm very impressed with the look of the ray tracing.

      Thanks for your help.

      Comment


        #4
        If you increase the number of samples on the skylight, you can get rid of the noise, at the cost of performance.

        Comment

        Working...
        X