Announcement

Collapse
No announcement yet.

Raytrace Glass material question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Raytrace Glass material question

    Hey guys ,

    Am struggling to get the reflection on the glass material in raytrace mode , but it seems that no matter how many method i try i never get a clean and clear reflection , specially if its from both sides , are we supposed to use the sphere reflection capture for the glass to get a reflection with the raytrace mode or is there a code i should add to enable glass reflection ,

    also it will be great if someone can help me to point out the latest effective glass material ,

    Thank you and wish u the very best

    #2
    To point out more about the issue , if you look at this webinar presentation you will see their engine version having sphere reflection captures even that they are using Raytrace , so this is really confusing fro me because i thought that we dont need to use sphere reflection captures any more after raytrace but it seems like theres more details in the subject ,

    https://evermotion.org/articles/show...dia-quadro-rtx

    Comment


      #3
      Do you have translucency enabled for raytracing? Not sure about the video(site isn't loading), but raytraced reflections can be masked by a particular roughness range for performance. They may use the precomputed cubemap reflections for roughness > 0.7 and raytraced reflections for roughness < 0.69 for example.
      Lighting Artist II @ Crystal Dynamics
      ArtStation
      Twitter

      Comment


        #4
        Thanks for ur answer, i did enable Translucency and glass ot really cleared and shadows are great but no reflection at all no matter how i keep trying different material or adding more depth to the glass panel , but when i add a sphere reflection i start to see reflection but they are not sharp and clear as they should like in the video in the evermotion site , which is really annoying as glass is one of the most important part of out ArchViz renders ,



        Comment


          #5
          So here is more about the problem , ive found a good reference for the glass material that is to the 4 mesh layer technique and have external and internal layer with glass material and the 2 in the middle to be just tint material , and once i enable raytrace translucency the direct light dosnt go through am not sure why and what am missing but am guessing it could be in the material part or something i ned to add so the glass can let the light go through , i have attached some images and the material details

          Comment


            #6
            once i enable raytrace translucency the direct light dosnt go through am not sure why and what am missing but am guessing it could be in the material part or something i ned to add so the glass can let the light go through
            https://docs.unrealengine.com/en-US/...portedfeatures

            Translucent Materials currently act like an opaque material meaning that it does not allow light to pass through. You can simply make the disable "cast shadow" on the glass asset in your level from the Details panel or you can open the static mesh that has the material applied and under the material slot, disable Cast Shadow for that specific material slot.
            Tim Hobson | Learning Resources | Epic Games
            UE4 Documentation

            Comment


              #7
              Originally posted by Tim Hobson View Post



              You can simply make the disable "cast shadow" on the glass asset in your level from the Details panel or you can open the static mesh that has the material applied and under the material slot, disable Cast Shadow for that specific material slot.

              Thanks Tim , this is actually what i did , but even after that when i try to render the scene in a sequence animated video the shadows dosnt show i dont know why and am trying to catch the compet dead line but all of this happen at the end , can you elebrate on why the shadows dosnt show in the render ,

              Thanks alot for ur help

              Comment


                #8
                I think I'm running into the same issue. I have a simple box room with only a single opening for a window. I then created a cube with a simple translucent shader to cover the window opening. It completely blocks all light like Tim suggested above.

                Disabling shadows lets light through, BUT the GI does not pick up the light that is spilling into the room. I still get black bounce even though i have a very bright light hitting most of the interior floor. If i create a plane instead of the cube, and the face normal is pointing into the room, then everything works as expected. No shadows from the glass and light is bounced around the room.

                It seems that the raytracing has trouble with more than 1 layer? I tried cranking up the number of refraction rays and quite a few other raytracing console commands without any improvement. Is anyone else experiencing this? Are there any known work-arounds besides glass with zero thickness?

                Comment

                Working...
                X