Announcement

Collapse
No announcement yet.

Strange model shadows?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Strange model shadows?

    So I made some custom wall models and I ported them into UE4 and when I built the Lighting they come out looking like this and I can't find a fix anywhere whatsoever if anyone knows if this could you please tell me as I don't know much about this since I'm just a beginner and I have no clue what problems causing this. Thank you!

    #2
    I just wanted to check back in and see if anybody still has a solution to this problem. if you do please tell me! thank you.

    Comment


      #3
      What do the walls' UV maps look like?

      Comment


        #4
        thats behause Unreal processes every mesh separately when Building light.
        You either want to merge the walls so it is only one mesh, use meshes to cover these seams or use GPULightmass (which is experimental)

        Comment


          #5
          ...or you can use the solution for modular pieces: 0.15 indirect level scale and 0.6 smoothness!!
          This will correct the adjustments Unreal is making...

          Comment


            #6
            Originally posted by Makigirl View Post
            ...or you can use the solution for modular pieces: 0.15 indirect level scale and 0.6 smoothness!!
            This will correct the adjustments Unreal is making...
            Where can I find these settings at?

            Comment


              #7
              ...under World Settings / Lightmass
              http://www.majart.ie/_include/img/tu...hdri/world.jpg

              Comment


                #8
                Originally posted by Makigirl View Post
                ...under World Settings / Lightmass
                http://www.majart.ie/_include/img/tu...hdri/world.jpg
                Ok so I tried this method and I built lighting and some shadows look like all nasty. (It looks like dirt on the walls.) im not sure what I can do to fix that. do you have an idea on how to fix it?

                Comment


                  #9
                  I guess your Quality is still on the default 1... if you need better quality you'll have to go higher... it will raise your building time!!

                  Comment

                  Working...
                  X