Announcement

Collapse
No announcement yet.

Ansel forces Ray tracing reflections. How to disable it? -solved

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Ansel forces Ray tracing reflections. How to disable it? -solved

    I start the engine with the -dx12 option to get the RT shadow. I have a scene with a post effect in which the reflections are forcibly set to SSR mode.
    In the camera settings (Cine Camera), the SSR mode is also forcibly enabled.

    When I start the game, everything looks correct (RT reflections is disabled).
    But when I use Nvidia Ansel, when I enable the "Hight quality" parameter (in the Ansel settings), RT reflections are turned on. This problem came with update 4.22.1, at 4.22 there was no such problem.

    Does anyone know how to forcibly disable the use of RT reflections in the game so that Ansel does not use them at all, but at the same time keep the RT shadows?


    I tried to use console commands (for example, r.RayTracing.Reflections=0) inside the editor window, and even in the game itself, but this does not help.
    Last edited by Lord-Kvento; 04-27-2019, 11:02 AM. Reason: correct

    #2
    I rummaged through the source code of the Ansel plugin
    (UE_4.22\Engine\Plugins\Runtime\Nvidia\Ansel\Source\Ansel\Private) and in the Ansel.cpp file I found the code responsible for forcing RT reflections.
    But whatever I change in this file, no changes occur, RT reflections are still turned on in the "Hight Quality" mode.

    How to remove these freaking forced RT reflections?
    Attached Files
    Last edited by Lord-Kvento; 04-27-2019, 03:32 PM.

    Comment


      #3
      Ok, I solved this problem.
      In case it is someone else need be, I did these steps:
      1. Open the engine and disable the plugin in the plugin settings and close the engine.
      2. in the Ansel.cpp file in line 866, I assigned the value of r.RayTracing.Reflections to 0 (instead of 1), and saved the changes to the file.
      3. Then I recompiled the plugin like in this video:

        Just keep in mind that after the
        Code:
        -package=
        command, you need to write another path (outside the folder with the engine) and nothing will come of it.
        For example, I wrote
        Code:
        -package="I:/Ansel"
      4. After that, I copied the files of the new plug-in to the folder with the old plug-in (with the replacement of files).
      5. Now open the engine and connect the plugin.
      6. Restart the engine and now everything works as it should! Now, on high quality mode, Ansel does not force RT reflections!
      Attached Files
      Last edited by Lord-Kvento; 04-27-2019, 04:32 PM.

      Comment


        #4
        Is the RT part of Ansel's own post-processing? If so r.Photography.AutoPostprocess 0 should be able to stop it (but haven't tested it yet).

        Comment

        Working...
        X