Announcement

Collapse
No announcement yet.

Black sun and light shaft artifacts when Physical Light is too bright

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Black sun and light shaft artifacts when Physical Light is too bright

    Hello,

    I'm using UE4.21.1 and I'm experiencing with Physical Lights some weird black artifacts. I think they are related with some kind of overflow since they're only appearing on GTX 9XX cards and not on 10XX cards, so maybe the quantity of the graphic card RAM is involved.

    Here two screenshots that show the issue:


    This is taken from a PC with a GTX 970 card (4096 MB memory)


    This is taken from a PC with a GTX 1060 card (6144 MB memory)

    Some details about the light:
    - Extend default luminance range in Auto-Exposure settings is ON
    - The light source is set to 125000 lux
    - The emissive skylight material is set to 70000
    - Of course, both screenshots use the same build data


    The "Apply Pre-exposure before writing to the scene color" fixes the issue but it breaks scene capture render targets.

    Any workaround/suggestions to this?

    #2
    If you cannot use pre-exposure your only option is to reduce your light intensities by a constant value, like 100, and adjust your exposure to compensate. Numbers that massive risk hitting precision limits on GPUs and can break when put through calculations.

    Comment


      #3
      This is very annoying, our team just hit this in 4.22.3. Something to keep in mind when using physical lighting values. 10 series is fine, but 9 series has these problems as shown above.
      My game: FisherBros - Platform and solve puzzles using a physics-based fishing rod.
      My policy: Need help or advice on a UE4 project feel free to PM me.
      My pocket money: Consultant at unrealconsulting.com

      Comment

      Working...
      X