Announcement

Collapse
No announcement yet.

Black Artifacts Displayed with Lightmap Density View

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Black Artifacts Displayed with Lightmap Density View

    Hello all -

    Hoping someone can help solve a strange behavior I'm seeing. Anytime I am in the "Lightmap Density" optimization view, I get some odd black artifacts showing up overlaid on the mesh with the lightmap density. This happens in a fresh project (using the VR template). Can anyone shed any light on some setting or thing I may have done to break it?

    See attached images. Thanks.


    #2
    More info after some testing - seems to be isolated to one machine. Running latest nvidia drivers on a pair of 1080 Ti's (425.xx drivers).

    Have tried uninstalling and reinstalling 4.22 - but to no avail.

    Comment


      #3
      Chasing this further -

      - Resetting / rolling back / updating nvidia driver (dual 1080 Ti's without SLI) does not help.
      - We have two identical machines in our office - the other one is fine - so its one machine.
      - It seems to only affect projects that use the VR template as their foundation. I made a third-person project and it behaves as expected.

      Anyone have any ideas?

      Comment


        #4
        Same here. I have narrowed down the issue - the lightmap density view will have black tearing/flickering/z-fighting/artifact (some keywords here for others to find this answer easier) if instanced stereo is enabled. I'll submit an issue on this.

        Comment


          #5
          Originally posted by ryantow View Post
          Chasing this further -

          - Resetting / rolling back / updating nvidia driver (dual 1080 Ti's without SLI) does not help.
          - We have two identical machines in our office - the other one is fine - so its one machine.
          - It seems to only affect projects that use the VR template as their foundation. I made a third-person project and it behaves as expected.

          Anyone have any ideas?
          oh, I'm using the vr template too. dang. wish someone could pinpoint the cause for this, I'm about to port a whole project to another template because of this

          edit: ok now I feel like an idiot. I misinterpreted the comment above this whole time. I read "i'll submit an issue on this" and didn't realize that instanced stereo was the cause and that turning off would fix it.

          dang. it's all good now, cheers
          Last edited by fael097; 06-04-2019, 06:03 PM.
          behance.net/fael097

          Comment


            #6
            You have to disable InstancedStereo and the black artifacts will disappear.

            Comment

            Working...
            X