Announcement

Collapse
No announcement yet.

Foot shadow wrong on the floor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Foot shadow wrong on the floor

    Hallo frinds, I very desperate, I don't understand because foot shadow on the floor for my Character are wrond like in attach image
    I try to set Physic body for lighting etc. but the problem is the same, the shadows arw so far to foot
    can anyone have a solution?
    I have think the problem is collision of the floor mesh but the collision is right
    I have try to place blueprint character (static) and the problem disappear but if I use normal character have this shadows

    thanks!

    #2
    What's most likely the issue is that when your character or its animations were being setup before being imported into the engine, the root joint of its skeleton wasn't properly horizontally aligned with the bottom of the character's. You can more easily check the distance between the character's feet and the floor in the animation preview window of the character. You have two options. So I highly doubt it's a rendering issue but an animation issue where whoever setup the character and/or animations wasn't properly watching for alignment issues.

    1. (Slightly more complicated but less likely to introduce bugs later on): Export the character and adjust the alignment of the root joint and feet and then reimport it.

    2. (Also Slightly complex, if you don't know how to use anim blueprints.): You can use the Modify bone node in the character's Anim BP to transform the hips/pelvis bone vertically donward and adjust it manually until it fits your needs.

    3. (Simpler solution but could cause clipping issues with other meshes): Lower the height of the floor's collision even if it looks right.

    Make sure to check the animations for misalignment, too
    Last edited by Riley1389; 02-08-2019, 10:02 AM. Reason: Grammar Mistakes

    Comment

    Working...
    X