Announcement

Collapse
No announcement yet.

My pretty textures are being washed out by lighting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    My pretty textures are being washed out by lighting

    I'm having issue with some of my materials, essentially I need to use a bright-light in my scene as a sunlight, but my colours are being severely washed out by it, and changing the hue and saturation of the textures is only going to end up giving me a non-realistic result. Changing the textures is really NOT an option, I need to tweak some part of the scene or the post-process to bring this out.

    I've tried a bunch of changes to the textures import settings, such as using Vector Displacement Map (for the best quality possible) and playing with SRGB, but to no avail. Even got rid of mip-maps incase that was the issue, but it's not. Here is my Earth texture inside the texture viewer (well, a small part of it anyway). Notice how much more dynamic range there is between the colours in the texture, and those in the scene. Even if I reduce the lights' intensity, the colours still get washed out.

    Click image for larger version

Name:	ImportedTexture.JPG
Views:	1
Size:	224.9 KB
ID:	1138102
    Click image for larger version

Name:	WashedOutEarth.JPG
Views:	1
Size:	265.6 KB
ID:	1138103

    And here is another example, my Milky Way texture, and the corresponding view in the viewport... all the clarity and dynamic range is lost completely. Something's being crushed somewhere... This is also an UNLIT material.

    Click image for larger version

Name:	MilkyWayTexture.JPG
Views:	1
Size:	215.3 KB
ID:	1138104
    Click image for larger version

Name:	MilkywayWashedOut.JPG
Views:	1
Size:	143.1 KB
ID:	1138105

    I've fiddled with Post-Process settings as much as possible. Here are my current ones, but I'm still not getting the colour information I'm looking for. Is there an easy way to sort this out, or a way I can get a better result? I've tweaked the settings as much as I can already...

    Click image for larger version

Name:	PostProcess.JPG
Views:	1
Size:	73.0 KB
ID:	1138106

    #2
    Post a pic of your material. Hard to say what it is without that. First guess is specular has no value or a high one.

    Also, did you try modifying any of the values in the texture adjustments window?

    Comment


      #3
      As TimeSpirit said check Specular. IIRC specular has a default value of 0.5 and gives me trouble sometimes. So whenever i create a material i always set a value of 0 to specular.
      Support my RTS Game (Agora) on Patreon!
      Unreal Nexus - Create Share and Experience!
      Unreal Engine 4 World-Wide User Map

      [PLUGIN] Aws Gamelift Client Plugin
      [TOOL] Create your own binary release of UE4 from GitHub source
      My UE4 Tutorials and Misc Tools

      Lead Programmer at YetiTech Studios
      Your Friendly Neighborhood
      Satheesh PV (a.k.a RyanJon2040) | Twitter, Instagram, Facebook, LinkedIn, YouTube, Google+

      Comment


        #4
        I would increase your dynamic range slider, check both crush highlights and shadows, and set those to 0. Contrast at such a low value is also going to remove variation between colors, potentially washing out your image. You could also use the milky way as a cubemap, and add a skylight while reducing your overall intensity for a secondary light bounce that might also bring out some more detail.

        Comment


          #5
          Originally posted by TimeSpirit View Post
          Post a pic of your material. Hard to say what it is without that. First guess is specular has no value or a high one.

          Also, did you try modifying any of the values in the texture adjustments window?
          It would take a pretty enormous monitor to display the whole material (some 350 instructions), but I can assure you it has very little specular value. Even if I was to plug the texture into just a 'base colour' slot and stick it on my Earth, it would do the same thing regardless of specular level.

          I previously had the Dynamic Range at 4.0 (the default), but that actually makes it worse. I like the idea of the Skylight, might give that a go. Although the shown images don't really look like it right now, I can't stress how important the 'realism' aspect is of this scene.

          Comment


            #6
            Have you come up with a resolution for your issue? I'm bound to run into this at some point, as well as others. How'd the skylight go?

            Comment


              #7
              Could be the antialiasing. That eats fine detail for breakfast.

              Comment


                #8
                I'm having the same problem. Lighting in UE4 seems to be a lot stronger than what I'm used to. Everything that looks good in other 3d softwares gets a lot brighter and saturated when used in UE4. For example, foliage materials that looks great in 3DO or Speedtree always end up too saturated in UE (for me). Lowering strength of light obviously reduce it but I feel like it's still saturating everything too much at default light settings. I guess it could be fixed using post process volumes but I haven't quite gotten the result I want yet. I haven't worked much on lighting yet. Would be great to hear from someone that is more experienced with lighting in UE about how to achieve a more "natural" light.

                Comment


                  #9
                  Try completely disabling the auto-exposure in your post process volume (or camera, if you're not using a volume). You can do it by setting both min and max exposures to 1.0.

                  Comment


                    #10
                    Originally posted by pedro_clericuzzi View Post
                    Try completely disabling the auto-exposure in your post process volume (or camera, if you're not using a volume). You can do it by setting both min and max exposures to 1.0.
                    Yep done that, no luck. I haven't been back to this scene yet, soon as I will I'll update on what I've tried since.

                    Comment


                      #11
                      I have the same issue with all materials in ue4. everything looks really washed out under normal lighting conditions. Did anyone find a resolution?

                      Comment


                        #12
                        I know your material is unlit but, does it look better if you set the viewport to Unlit view? it could be the lighting, the postprocessing, the AA, or something in the material or the texture itself. seeing it in Unlit will clear out some of these possibilities (as Unlit disables lighting, postprocessing and AA)
                        Follow me on Twitter!
                        Developer of Elium - Prison Escape
                        Local Image-Based Lighting for UE4

                        Comment


                          #13
                          I think it's Tonemapping.

                          Comment


                            #14
                            That Necro hahaha... yeah it was partially tonemapping. Bloom and various other factors contributed too, took a lot of tweaking to get it right. It never looked exactly like the original image, but you just have to be prepared for UE to put it's own twist on things

                            Material was lit btw, not unlit. Universe skybox was unlit however.

                            Comment


                              #15
                              See if this trick helps or is relevant: Linear RGB in UE4

                              You can use this pow(x, 2.19) trick for both solid color verts and for textures. Worked for our project.

                              Good luck!
                              @charlestoeppe

                              Comment

                              Working...
                              X