Announcement

Collapse
No announcement yet.

Waiting for my eyes to adjust to the light?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Waiting for my eyes to adjust to the light?

    Hello, I'm a beginner at trying to develop a game. When moving between areas with different levels of light the camera takes time to adjust to the new lighting. For example I have a hallway that is lit only by evenly spaced openings in the ceiling that let light in from the one Directional light that I'm using as a sun. These opening are spaced fairly far apart. If I'm standing in the hallway looking towards an area with an opening and then turn the other way the scene is almost completely black then slowly brightens. Is there some way to disable this? I have tried playing with different settings (that I know nothing about). This happens in the editor and it is very annoying when trying to design a level. There is also something related happening in the SM viewer. Every time I move the camera the lighting on the SM changes and takes a few seconds to adjust.

    Another question is how to get more ambient brightness across my whole map? I am making a cartoony type environment and would like to have the lighting be more uniform everywhere, kind of like it is in Fortnite BR but maybe not to that extreme.

    Thank you for any replies.

    #2
    Fortnite is more ambient because it's all dynamic lighting, which doesn't support the intricate details available with baked lighting. If you're using baked lighting, you have a lot more options to achieve different results, like increasing your ambient light sources direct(or indirect) intensity, increasing specific light ambient intensities, disabling shadows on the Sky Light, etc.

    As for the auto-exposure, you can disable it in the Post-Process Volume or project settings. Or if you want to adjust the range that it adjusts down or up to, or increase the time it takes to adjust, you can do that in the Post-Process Volume.

    Edit: I forgot, if you're really want a flat ambient across the map, try disabling the Sky Light altogether and use the Environment Color in the World Settings. Or use a white cubemap texture in the Sky Light and tint it with the Sky Light settings.
    Lighting Artist II @ Crystal Dynamics
    Former Lighting Artist @ Obsidian Entertainment
    ArtStation

    Comment


      #3
      Thank you for the reply. It's much appreciated.

      I had auto-exposure unchecked in the project settings and metering mode unchecked in the post-processing volume but I had somehow missed the Min/Max Brightness settings. That was it. In UE2 there was a simple setting for Ambient Brightness. Even though it washed out the well lit areas it was good for brightening areas that were very dark. Min Brightness seems to do that but no matter what I set the Speed Up/Down settings to there is always a slight delay. I haven't built lighting yet and tried in game but in the editor window I can't get it to behave the way I want. I will play around more. Thanks again for the information. I have a lot to learn and you have helped me with that.

      Edit: Nevermind about the slight delay. I got it.
      Last edited by Tim-0202; 01-13-2019, 09:14 PM.

      Comment

      Working...
      X