Announcement

Collapse
No announcement yet.

How to disable Temporal AA, not just in the editor?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    How to disable Temporal AA, not just in the editor?

    I have disabled temporal Anti Aliasing in the engine quick settings as it is causing terrible flickering, but when I enter the game itself it is still there. I found a thread about this, and they said to make sure it is turned off in the post processing effects details tab if you have any placed in your level. Well I checked mine and I do not even see the option for it in the only post processing I have, so I'm unable to turn it off. Would anyone be able to help me with this? I honestly don't think there's an option for it from what I can see.

    #2
    It used to be in post process settings in volumes and cameras, now you can change/disable it in Project Settings > Rendering > Default Settings.
    FREE VR Drum Kit Project
    FREE Color LUT Collection
    FREE Physics Driven Spacecraft Project
    FREE GTA Style Vehicle Interaction
    Dynamic DoF(Depth of Field)
    Camera Crossfade

    Comment


      #3
      Originally posted by Jacky View Post
      It used to be in post process settings in volumes and cameras, now you can change/disable it in Project Settings > Rendering > Default Settings.
      Thank you so much that fixed the problem! I was also able to turn off auto exposure as well which I was also having trouble with.

      There is one other potential problem though, I tried both FXAA and MSAA, and neither seem to be doing anything as far as I can tell in the game. Any idea why that may be?

      Comment


        #4
        FXAA should work, but MSAA requires Forward Rendering(enabled in project settings, has its own limitations.)
        FREE VR Drum Kit Project
        FREE Color LUT Collection
        FREE Physics Driven Spacecraft Project
        FREE GTA Style Vehicle Interaction
        Dynamic DoF(Depth of Field)
        Camera Crossfade

        Comment


          #5
          Originally posted by Jacky View Post
          FXAA should work, but MSAA requires Forward Rendering(enabled in project settings, has its own limitations.)
          I can't really tell any difference between FXAA being on or off, is there more settings in regards to how strong it will be applied or something?

          Comment


            #6
            It does work but less noticeable than Temporal AA.

            No AA
            Click image for larger version

Name:	NOAA.JPG
Views:	1
Size:	6.5 KB
ID:	1571660

            FXAA

            Click image for larger version

Name:	FXAA.JPG
Views:	1
Size:	5.8 KB
ID:	1571661

            However you can use sg.AntiAliasingQuality 0, 1, 2, etc. console command to switch between quality settings.
            FREE VR Drum Kit Project
            FREE Color LUT Collection
            FREE Physics Driven Spacecraft Project
            FREE GTA Style Vehicle Interaction
            Dynamic DoF(Depth of Field)
            Camera Crossfade

            Comment


              #7
              Thank you, you are right the difference is subtle. I was trying to figure out if there's a way to get rid of the jagged edge movement when moving the character during gameplay?

              Comment

              Working...
              X