Announcement

Collapse
No announcement yet.

Black shadows and issues with normal map

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Black shadows and issues with normal map

    Getting bad lighting on these meshes. It seems to be related to the normal map? Also included a screenshot of the same asset/textures in marmoset for comparison. Could it be something to do with lightmaps (I didnt unwrap UV2 manually)?

    #2
    Make sure that the normal map is set to use normal map compression
    If that doesn't work, you may need to invert the green or red channels.

    Comment


      #3
      Compression is set to "Normalmap (DXT5, BC5 on DX11)". Tried flipping the channels but it doesn't affect that seam in any way. Also, these were exported from substance painter with the UE4 preset that already flips the green channel i think. This seems to be more of a lighting issue in ue4? I can't replicate it in other rendering softwares

      Comment


        #4
        How does your normal texture look like?
        Try checking/unchecking "Tangent Space Normals" in your Material.
        Also double check your mesh Normals.

        Comment


          #5
          Thank you guys so much for ur help
          With tangent space normals turned off the object looks almost completely black. Also, attached a screenshot of the normal map and settings.

          Comment


            #6
            I brought the same asset into another older project and it looks fine there (screenshot attached). Could it be something about the lighting or other settings thats causing the issue in the other project?

            Comment


              #7
              Ok figured it out there was something wrong with the master material. Re-creating it solved the issue. Thanks everyone for ur help

              Comment


                #8
                Originally posted by shilbose View Post
                Ok figured it out there was something wrong with the master material. Re-creating it solved the issue. Thanks everyone for ur help
                Would you mind sharing your materials or explaining what you did differently? I am currently facing the exact same problem where my normal maps are causing weird problems with lighting. I got them from substance painter's UE4 texture export. Thanks in advance.

                Comment


                  #9
                  Hello! I had the same issue while importing my model.
                  The problem was the normal map channel.
                  To solve it, I simply entered the "material" then found my "normal map".
                  I've only changed the "Texture sample block" of my normal map from RGB to Blue.
                  Then I connected it to my "Material Result Node", in "Normal Map" spot.
                  That' all.

                  Changing from RGB to Blue channel worked perfectly!
                  I hope it can help everyone with my same problem in future!

                  Keep safe!

                  Comment

                  Working...
                  X