Announcement

Collapse
No announcement yet.

Lighting 'clitching' through walls.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Lighting 'clitching' through walls.

    Hello,

    I'm having this small problem with a blockout I made in 3DSmax. Since it's a blockout and I wanted it to be procedural. So, I used a Loft system to construct the blockout. I also used a Shell modifier on it just to be sure the light wouldn't 'clitch' through it due to the backface culling. (But this sadly didn't work.)
    I also converted everything to an editable poly, reset the normals and Xform. I also screwed around with some of the settings of the mesh and light in Unreal but so far, it didn't really work. I'm hoping someone here knows how to solve this.

    I mostly make natural, open world environments. So I have no clue how to solve it. (Or I've already tried the things I knew).
    If someone could help me out here, that would be much appreciated!

    -Bram

    #2
    If a surface is visible on the outside then it can have lighting bleed onto the inside surfaces because the pixels in the lightmap don't line up perfectly with the edges.

    Comment


      #3
      Originally posted by darthviper107 View Post
      If a surface is visible on the outside then it can have lighting bleed onto the inside surfaces because the pixels in the lightmap don't line up perfectly with the edges.
      Oooh. That makes sense! So what I should do (for the blockout) is just disable the lightmap so the lighting doesn't bleed through it? I haven't baked anything and all the lights are on movable (Except for the mesh, that one is static). Thanks for the fast response though!

      Comment


        #4
        Solved: Since it was a blockout I didn't really unwrap anything. So I did a quick, basic automatic unwrap in 3DSmax and exported it to Unreal. It all works now! I believe UE4 can also do the job for you but this works fine for just the blockout stage. I also gave it some thickness due to backface culling. But I think, by adjusting some settings un Unreal, that shouldn't be a problem as well

        Comment


          #5
          If you're using movable lights then the issue can happen due to the shadow bias setting of the light (where the shadow doesn't look like it's connected to the object casting it)

          You can get better lighting with baked lights though so I recommend setting that up properly. Just try to avoid meshes intersecting (have them line up exactly) or you can try to block the light from the outside (giving exterior surfaces to block the light)

          Comment

          Working...
          X