Announcement

Collapse
No announcement yet.

I dont get why metal materials are appearing black (using Metal/Rough workflow in both UE/Painter)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    I dont get why metal materials are appearing black (using Metal/Rough workflow in both UE/Painter)

    I dont understand why Metallic parts of my van are black in UE4. I know how it can alter by using spec/gloss in painter because UE4 uses Metal/rough. So i am defeinitely using metal/rough in painter. I am also using "bonaficio aragon stairs" environment map in painter because its at the seasisde and my scene is also at the seaside.

    This is a painter screenshot


    and this is what it looks like in UE4




    Whats going on?

    #2
    Originally posted by Stewart774 View Post
    I dont understand why Metallic parts of my van are black in UE4. I know how it can alter by using spec/gloss in painter because UE4 uses Metal/rough. So i am defeinitely using metal/rough in painter. I am also using "bonaficio aragon stairs" environment map in painter because its at the seasisde and my scene is also at the seaside.
    Have you painted the albedo of the metal parts in a bright colour? UE4 doesn't treat metal like raytraced renderers, so you need a bright colour (usally a light grey or white).

    Comment


      #3
      Your basecolor for metals should contain specular color, not albedo.

      Comment


        #4
        Do you have a Reflection Probe and/or a Sky Light in your scene?
        Lighting Artist II @ Crystal Dynamics
        ArtStation
        Twitter

        Comment


          #5
          ^ Most likely the issue. Need ReflectionSphere or ReflectionCube in scene or there is nothing to reflect.

          Comment


            #6
            In particular, every inch of your level needs to be covered by at least one reflection capture, or you will have areas with zero specular, and metal only has specular with no diffuse due to the physics of light.

            Comment


              #7
              Originally posted by Pixelpirates View Post

              Have you painted the albedo of the metal parts in a bright colour? UE4 doesn't treat metal like raytraced renderers, so you need a bright colour (usally a light grey or white).
              Originally posted by Deathrey View Post
              Your basecolor for metals should contain specular color, not albedo.
              Im really sorry for the late reply. Been extremely busy this last week not had chance to work on this scene.

              I think this may be the issue because I already have reflection captures in the scene like others pointed out (thanks for the help though)

              How do I rectify this in painter?

              Comment


                #8
                Have you tried disabling sRGB on your roughness and metallic maps?

                Comment


                  #9
                  Originally posted by Stewart774 View Post



                  Im really sorry for the late reply. Been extremely busy this last week not had chance to work on this scene.

                  I think this may be the issue because I already have reflection captures in the scene like others pointed out (thanks for the help though)

                  How do I rectify this in painter?
                  If you already have some sort of ambient specular source in the scene(SkyLight, Reflection Actors...), then it's down to your textures and/or material.

                  Your metals need to have a Base Color value above 180 sRGB and they need to have pure white in the Metalness. Also make sure your RMA or individual Roughness/Metalness/AO textures have sRGB disabled to ignore gamma correction.
                  Lighting Artist II @ Crystal Dynamics
                  ArtStation
                  Twitter

                  Comment


                    #10
                    Originally posted by rosegoldslugs View Post

                    If you already have some sort of ambient specular source in the scene(SkyLight, Reflection Actors...), then it's down to your textures and/or material.

                    Your metals need to have a Base Color value above 180 sRGB and they need to have pure white in the Metalness. Also make sure your RMA or individual Roughness/Metalness/AO textures have sRGB disabled to ignore gamma correction.
                    Thanks man. Definitely got sRGB unchecked, sorry how do I change/check it? In painter i'm not sure how to change specular colour

                    Comment


                      #11
                      This is my Metallic channel in my packed RGB texture, its all white. I still dont know whats happening

                      Comment


                        #12
                        ... so that’s what’s wrong with my metal materials. Well this is awkward.

                        So then if the basecolor input is actually specular color, where do I find physically accurate values for different metals? Do I just have to eye it?

                        Comment


                          #13
                          There's PBR charts online everywhere. Just Google pbr chart, for metals in particular you need to stick to the values on the chart if you really want metals to look accurate.

                          Comment


                            #14
                            That’s normally what I do. But isn’t that usually an albedo value?

                            Comment

                            Working...
                            X