Announcement

Collapse
No announcement yet.

Weird looking textures

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Weird looking textures


    I'm new to the Unreal engine. I'm used to working in unity.
    I have a problem with setting up the material with textures exported from SubstancePainter. The first problem is that the model looked too glossy with png textures, I exported textures in tga format and the model began to look much better, but it is a bit glossy and dark anyway. The second problem is that the normal map works weird, it is look like the model is in smooth shading.

    Here is how it looks in UnrealEngine
    https://i.imgur.com/UzNbPry.jpg
    https://i.imgur.com/sCqlA8r.jpg
    Here is how the same model looks in Unity
    https://i.imgur.com/w6qCkk7.jpg
    https://i.imgur.com/S5lzzbv.jpg
    Model with and without normal map in Unity
    https://i.imgur.com/XMYMFP7.jpg


    #2
    PNGs have their own gamma correction, so I'd avoid them since they flip the workflow required for some textures.

    After importing your Roughness, make sure it has sRGB unchecked in the texture settings. That should be all you need to do, but if you import a RMA or any other merged texture with Roughness, also make sure it doesn't have Normal Map compression in the same texture settings window.

    Assuming the textures are imported correctly, and the material is correct, the darkness is likely from the ACES tonemapper, which is not supported by default in Substance Painter(I made a LUT in Nuke for it) and isn't enabled by default in Unity(I think).

    For your normal maps, make sure the green channel is inverted. If you export your Painter normal map as DirectX, it will flip it for you, otherwise you can do that in the texture settings after importing in Unreal.
    Lighting Artist II @ Crystal Dynamics
    Former Lighting Artist @ Obsidian Entertainment
    ArtStation

    Comment

    Working...
    X