Announcement

Collapse
No announcement yet.

Shader Complexity viewmode showing odd results

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Shader Complexity viewmode showing odd results

    Hi,

    I'm helping a mate out with a project that I'm mostly unfamiliar with and I'm seeing some weird results when looking into graphical performance hitches. As part of diagnosing this, I made a new Default level (so just a box/DefaultMaterial) and the shader complexity looks like it's being reported incorrectly - even a basic mat with a colour and a couple of constants hooked up (no textures at all) is reporting as overly complex. A similar scene in a different project looks as expected, very cheap.

    I'm wondering what else could be affecting shader complexity since the numbers all look fine (~500 instructions SM5), maybe there's some buried project setting that might be throwing everything out of whack? I could do with establishing if something has gone awry deeper in the project or if the complexity is just being reported incorrectly.

    Thanks,
    triff

    Here's what I'm seeing when making a new 'Default' level and turning on Shader Complexity. Here's a different project showing expected results on a basic scene.

    #2
    Are you in forward rendering mode?

    Comment


      #3
      Sorry, meant to include that - no it's deferred. One directional + skylight, basic post process, nothing fancy going on that I can tell.

      Comment


        #4
        If I delete everything from one of their levels and then add one static mesh with a basic mat, it's straight into the red in Shader Complexity. :?

        Comment


          #5
          I saw a bug in 4.19 where the auto-exposure was affecting all visualization view modes (shader complexity, normals, etc). Try disabling it in the viewport and see if it helps.

          Comment


            #6
            Thanks for the suggestion, but no joy.

            I've migrated a level to a fresh project in a standard 4.20 Epic build and I'm seeing some weird stuff in the material stats too when comparing numbers, which is in-line with what the Shader Complexity view is telling me. Very odd.

            Comment

            Working...
            X