Announcement

Collapse
No announcement yet.

How to stop niagara particles fron getting killed on deactivate? Or workaround.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    How to stop niagara particles fron getting killed on deactivate? Or workaround.

    I have this basic emitter when you create new niagara emitter(particles going up and then falling). When I deactivate it, the particles already spawned are getting killed. Is there an option to stop that? Or alternatively a way to set spawn rate as parameter and then change it in blueprint. Currently I have a spawn rate set as a float curve from age and it works fine for now, but I will need it to be dynamic in the future.
    Last edited by Dark Energy; 10-11-2018, 09:16 AM.

    #2
    I'm still starting to understand Niagara, but I think you can create an User variable on the Niagara System and use that variable as Spawn Rate. Then, you should be able to control that variable's value with Blueprints.
    Freelancer Game Dev Generalist and Unreal Consultant | Portfolio
    Unreal products: Dynamic Picture Frames, Neo Kinect

    Comment


      #3
      Originally posted by RVillani View Post
      I'm still starting to understand Niagara, but I think you can create an User variable on the Niagara System and use that variable as Spawn Rate. Then, you should be able to control that variable's value with Blueprints.
      When I set it to variable engine.spawnrate I get compile error, but if i set it to engine.age it's fine

      Comment


        #4
        But for a custom variable that you access as a parameter on the System, it must be part of the User variables. So it would be something like user.spawnRate. Then you use that as the spawn rate value.
        Freelancer Game Dev Generalist and Unreal Consultant | Portfolio
        Unreal products: Dynamic Picture Frames, Neo Kinect

        Comment

        Working...
        X