Announcement

Collapse
No announcement yet.

How to achieve a late 1980s-Early 90s CGI film look?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by Manoel.Neto View Post

    Also, terrible models, robotic animations and poorly designed tiling textures. Also, use bump maps instead of normal maps (I'm sure there's a material node for generating normals from bump height maps). Only tiling bump maps, none of the fancy normal map baking people have nowadays.
    I know CrazyBump can convert height maps to normal maps so that they can be used in Unreal.


    Originally posted by IronicParadox View Post
    You can do this easier by editing things like the BRDF.ush and ShadingModels.ush. Within the "FDirectLighting DefaultLitBxDF" part of the ShadingModels, you'd just have it call a phong shader within the BRDF file(I believe there is already one in there).
    Thanks for that- it helped. I found a video that shows the phong shader in action, so I know it's definitely possible.
    https://www.youtube.com/watch?v=8J4Savam26M

    Now I'm assuming that with this phong shader (unlike the one I previously mentioned) the opacity of the specular highlight isn't affected by opacity of the object, because if that's the case then your solution is perfect.

    I would really like to know how to do something like this, because I'm pretty pleased by the results. Any tutorials/advice/guides on using/editing BRDF?

    Comment


      #17
      Originally posted by AnkurRastogi View Post
      All you need to do is remove the modern day graphics available for games and you would have the look
      Prerendered CGI had a very different look from real time CGI. It's not like you could PLAY a CGI movie from the 1980s-1990s. Back then the computers were't nearly fast enough for real time to look anywhere near as good as prerendered.
      Last edited by tapirtoon; 10-21-2018, 02:51 PM.

      Comment


        #18
        In the BRDF.usf file mentioned earlier, there should be number slots from like 1 to 4 or something and below that is a line that specifies which number is the active diffuse model and specular model. You can easily just swap the number active for the one that has your preferred shading model and recompile all shaders to see what it does.

        It should look somewhat like:

        (1) phong
        (2) Blinn
        (3) GGX
        (4) whatever

        somethingsomethingUseReflectionblablaModel = 3

        and then swaü that 3 for whatever you want (again, just an example....I dont remember it exactly as I havent used it for years now)

        But this is pretty neat as you can switch the diffuse model to OrenNayar

        Also, really delete all reflections, no skyight etc! Just use the cubemap feature inside the PP volume and add a solid color texture of your linking and turn down the intensity quite a bit.

        Oh and looking at youre reference, this really needs crappy models and textures to work...there is no way around that. Just look at the smoothing of those goat heads man XD

        Cheers!
        Check out UNREAL 4 Lighting Academy
        https://forums.unrealengine.com/show...ng-like-that-)

        Comment


          #19
          Originally posted by Daedalus51 View Post
          In the BRDF.usf file mentioned earlier, there should be number slots from like 1 to 4 or something and below that is a line that specifies which number is the active diffuse model and specular model. You can easily just swap the number active for the one that has your preferred shading model and recompile all shaders to see what it does.

          It should look somewhat like:

          (1) phong
          (2) Blinn
          (3) GGX
          (4) whatever

          somethingsomethingUseReflectionblablaModel = 3

          and then swaü that 3 for whatever you want (again, just an example....I dont remember it exactly as I havent used it for years now)

          But this is pretty neat as you can switch the diffuse model to OrenNayar

          Also, really delete all reflections, no skyight etc! Just use the cubemap feature inside the PP volume and add a solid color texture of your linking and turn down the intensity quite a bit.

          Oh and looking at youre reference, this really needs crappy models and textures to work...there is no way around that. Just look at the smoothing of those goat heads man XD

          Cheers!
          Originally posted by IronicParadox View Post
          You can do this easier by editing things like the BRDF.ush and ShadingModels.ush. Within the "FDirectLighting DefaultLitBxDF" part of the ShadingModels, you'd just have it call a phong shader within the BRDF file(I believe there is already one in there).
          ...edited...
          Last edited by tapirtoon; 04-01-2019, 03:29 PM.

          Comment


            #20
            Originally posted by Daedalus51 View Post
            In the BRDF.usf file mentioned earlier, there should be number slots from like 1 to 4 or something and below that is a line that specifies which number is the active diffuse model and specular model. You can easily just swap the number active for the one that has your preferred shading model and recompile all shaders to see what it does.

            It should look somewhat like:

            (1) phong
            (2) Blinn
            (3) GGX
            (4) whatever

            somethingsomethingUseReflectionblablaModel = 3

            and then swaü that 3 for whatever you want (again, just an example....I dont remember it exactly as I havent used it for years now)

            But this is pretty neat as you can switch the diffuse model to OrenNayar

            Also, really delete all reflections, no skyight etc! Just use the cubemap feature inside the PP volume and add a solid color texture of your linking and turn down the intensity quite a bit.

            Oh and looking at youre reference, this really needs crappy models and textures to work...there is no way around that. Just look at the smoothing of those goat heads man XD

            Cheers!
            Thanks for your advice! I finally found out how to modify the BRDF.ush file (in version 4.21) in order to use phong shading. I had to look at the source code for the 4.10 version (the last version to allow to easily switch between diffuse and specular models). I had modify the D_GGX function to use Blinn Phong specular instead.


            I had to change from this:

            Code:
            float D_GGX( float a2, float NoH )
            {
                float d = ( NoH * a2 - NoH ) * NoH + 1;    // 2 mad
                return a2 / ( PI*d*d );                    // 4 mul, 1 rcp
            }
            to this:

            Code:
            float D_GGX( float a2, float NoH )
            {
                float d = 2 / a2 - 2;
                return (d+1) / (2*PI) * PhongShadingPow( NoH, d );        // 1 mad, 1 exp, 1 mul, 1 log
            }
            I tested this with a custom version of the engine and it works! This is much better than "faking" phong shading highlights via an emissive. There is proper shadow mapping so the highlights will be properly obscured by cast shadows, like they're supposed to be.




            I used the movie Toy Story for reference

            Toy Story(1995):

            Screenshots from the modified version of the Unreal Engine (using blinn-phong for specular model)




            Thanks again for helping! I will now be able to create my game! I hope this helps anyone else that also wants to use blinn/phong instead of GGX for their project.
            Last edited by tapirtoon; 04-01-2019, 03:51 PM.

            Comment


              #21
              Originally posted by ZacD View Post
              Took the Infiltrator demo. Some of these steps are going to be redundant or cancel each other out, but it's the steps I took without much planning.

              Force No Precomputed Lighting

              Disabled screen space reflections and ambient occlusion in the post processing. Disabled bloom.

              Deleted every reflection capture.

              Deleted everything related to fog/cloud/godray

              Deleted decals.

              Created skylight, set to moveable, disabled lower hemisphere is black. This adds the flat ambient lighting.

              Set scalability settings to low.

              Switch to forward rendering and disabling extra features.








              Next steps would be to disable normal maps, fix some of the materials, replace materials and textures with lower resolution ones, with more tiling. Remove some of the extra lights.
              Any particular reason you recommended forward rendering as opposed to deferred?

              Comment


                #22
                Originally posted by tapirtoon View Post
                Any particular reason you recommended forward rendering as opposed to deferred?
                ...bump...

                Comment


                  #23
                  Originally posted by tapirtoon View Post

                  ...bump...
                  forward rendering will enable you to use MSAA if you want sharper looking images, in general terms forward rendering was the only type of rendering technique pre-defered used back then even in its lower spec form. It also allows lights and materials to act a little differently. But at all costs IMO TAA should be avoided f you want to help fake that old look for the obvious reason that it blurs the edges and makes things look too smooth and washed out.







                  Comment


                    #24
                    Originally posted by William K View Post

                    forward rendering will enable you to use MSAA if you want sharper looking images, in general terms forward rendering was the only type of rendering technique pre-defered used back then even in its lower spec form. It also allows lights and materials to act a little differently. But at all costs IMO TAA should be avoided f you want to help fake that old look for the obvious reason that it blurs the edges and makes things look too smooth and washed out.
                    Ok, thanks again. I also downloaded the old DOS Autodesk 3D Studio from 1990-1993 so I can test render my scenes with an old fashioned renderer (for reference). Surprisingly, .3ds files from 2019 still work in the old 90s software.

                    Comment

                    Working...
                    X