Announcement

Collapse
No announcement yet.

Weird Baking of Lighting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Weird Baking of Lighting

    I've discovered an odd problem with baking onto my objects when they are static. The reflective metal parts are receiving the sky and clouds, baked into the texture. Even if I tell the SkyLight to not cast volumetric fog, this happens. Also, the objects don't have complete shadows on the ground despite using production quality. The environment is a default Unreal template. The objects were made in Blender.

    In the first picture, the left one is static and the right one is moveable.
    In the second picture, the top shadow is static and the bottom shadow is moveable.

    Thanks for any help.
    Attached Files
    Last edited by SullenSecret; 10-05-2018, 12:12 PM.

    #2
    You're going to have to post a screenshot

    Comment


      #3
      I edited the first post to add screen shots. Sorry, I didn't have time earlier.

      Comment


        #4
        The lightmap resolution is too low
        In the first shot the black areas of the lightmap are bleeding around the axe blade which is why you see that dark blur which will go away when you increase the resolution.
        In the second shot, the mesh that's receiving the shadows needs to increase the lightmap resolution to make it more detailed/sharp

        Comment


          #5
          Originally posted by darthviper107 View Post
          The lightmap resolution is too low
          In the first shot the black areas of the lightmap are bleeding around the axe blade which is why you see that dark blur which will go away when you increase the resolution.
          In the second shot, the mesh that's receiving the shadows needs to increase the lightmap resolution to make it more detailed/sharp
          Oh, I see. What I mistook for clouds was actually the result of low resolution. Thanks. I discover new things all the time.

          Comment


            #6
            I'm back. I've learned about lightmap resolution and making my own LM UV channel in Blender, laying it out in a good way instead of going with Unreal's auto version. It looks the same. In this picture, the left one is at a LM resolution of 128 and the right one is at a LM resolution of 512. Even when cranked up to a ridiculous number, there is some dark color. What's up? Thanks for any answers. BTW, I may try giving the metal parts a huge area on the UV and see if that helps.

            UPDATE: I laid out a LM UV version that is more generous to the metal areas and it still had tons of dark areas, though there are less. I should mention that none of the UVs have islands that are very close (at least where the metal areas are). I am quite confused. Also, the handles are perfectly shaded. Does Unreal struggle with static lighting on metal? I may just avoid it.
            Attached Files
            Last edited by SullenSecret; 10-15-2018, 12:23 PM.

            Comment

            Working...
            X