Announcement

Collapse
No announcement yet.

Disable Texture Streaming or Force Max LOD for certain actors/meshes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Hmmm, looking over our scenes it is a pretty monumental task to flag everything. We have a ton of small buttons, indicators, nameplates, etc. with fine text on them.

    Seems strange that the SceneCapture2D doesn't render at the correct LOD. It is very close to the objects it renders.

    Leave a comment:


  • replied
    Originally posted by Flashback View Post

    Have you ever implemented this setup? I'm having the exact same problem.

    EDIT: After more digging, I found this solution on AnswerHub:
    Code:
    Mesh Component -> Force Mip Streaming checkbox
    Did the trick for me.
    Oh nice. Will try this. Looks like in C++ you can toggle it dynamically with:

    "component->bForceMipStreaming = true;"

    But, so far we haven't seen any performance issues just disabling texture streaming on the entire project ...
    Last edited by Shmoopy1701; 12-12-2019, 12:59 PM.

    Leave a comment:


  • replied
    Originally posted by Shmoopy1701 View Post
    With a SceneCapture2D placed near the magnified actor.
    Have you ever implemented this setup? I'm having the exact same problem.

    EDIT: After more digging, I found this solution on AnswerHub:
    Code:
    Mesh Component -> Force Mip Streaming checkbox
    Did the trick for me.
    Last edited by Flashback; 12-05-2019, 04:51 PM.

    Leave a comment:


  • replied
    Originally posted by OwenWP View Post
    UE4 automatically takes FOV into account for LOD distance, so zooming in should work fine. How are you magnifying objects?
    With a SceneCapture2D placed near the magnified actor.

    Leave a comment:


  • replied
    UE4 automatically takes FOV into account for LOD distance, so zooming in should work fine. How are you magnifying objects?

    Leave a comment:


  • Disable Texture Streaming or Force Max LOD for certain actors/meshes

    Situation: game has "picture in picture" to magnify distant objects.

    Problem: the magnified objects look like horrible/blurry because they are using lower LOD/Mip levels

    How to fix this? Either in code or in mesh settings. Currently we are attempting to use:

    Code:
    UStaticMeshComponent->SetForcedLodModel(1);
    on magnified objects but it just doesn't do anything. Is it incompatible with Texture Streaming which is on by default in the engine?
Working...
X