Announcement

Collapse
No announcement yet.

why do i get these lighting errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    why do i get these lighting errors

    i'm very new at unreal wanted to get into using the lighting tools. i decided to play about with the skylight to try and light this interior scene. i noticed some artifacts appearing when i bake the lighting out. the most noticeable is the image at mid settings with the weird artifacts near the top which is the image on the left. they seem to go when i put it on production. however on the wall on the right there seems to be some a lot of noise. i thought this might be a resolution problem so increased it to 512 which is i guess it is quiet large, but it made the noise smaller. how do i get smoother lighting and better results at mid settings.
    Last edited by electroraven1; 09-07-2018, 09:54 AM.

    #2
    Hello

    1.Be sure to have a correct UV2 lightmap (should'nt be too complicated for basic walls).
    2. Build in production and set enough rays and sampling by changing Static lighting level scale to 0.1 and Indirect lighting Quality to 10.

    To avoid artefact, you need to play with the Indirect lighting Quality and be sure to build with the production build to use the maximum settings. Basically, try to respect a ratio of 1/10. So 1 static lighting level scale will use 1 for the indirect lighting quality solver. 0.5 will use 5, 0.2 will use 8, ect.
    Lighting artist - Sumo Digital
    www.quentinpapleux.com

    Comment


      #3
      As per the image you have light coming from the outside. So make sure your walls are perfectly snapped and not intersected (intersection in wall mesh will again result in artifacts). Additionally its always a better idea to use light blocker to avoid any further light leak.
      Now for the artifacts there are few key values to be checked :
      - Visualize the lightmap density, should be a good amount in your case as most of your shadows are very soft.
      - To capture fine details you need to have a lower "Static Lighting Level Scale" in Lightmass settings (0.15-0.35) is a good value with "Indirect Lighting Quality" set to 3-5 and "Indirect Lighting Smoothness" set to something like 0.45 should do it
      - For testing purpose build it in Medium quality to save you time and get all the details

      Hope this helps

      Cheers

      Comment


        #4
        Thanks a lot for your reply. i set the static lighting scale to 0.1 and light bounces to 10. i found the source of the artifact. it turned out i the mesh managed to get multiple faces inside itself. i have no idea i however manage to do since i did clean up in maya. btw the you have any good resources for someone beginning in unreal and understanding the method of lighitng.

        Comment


          #5
          Lighting Academy by Daedalus51 is the best tutorial series i have come across so far. He starts from the very basic and you would learn a lot going thru all the tutorials
          Also you can check Unreals Online Learning also https://academy.unrealengine.com/Browse/architect
          Cheers!!

          Comment


            #6
            Thanks for the shout!

            I think looking at some of the content I provide would really help to give you a fundamental understanding. so feel free to check it out!



            Apologies for the horrible mic quality...it gets better at some point with later sessions^^
            Check out UNREAL 4 Lighting Academy
            https://forums.unrealengine.com/show...ng-like-that-)

            Comment

            Working...
            X