Announcement

Collapse
No announcement yet.

Issues with VR rending since 4.20 (using DirectX)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Issues with VR rending since 4.20 (using DirectX)

    So!

    After updating 4.20 from the preview build to the release build, this happened:


    (Uncompressed version: https://i.imgur.com/wWCZhfT.jpg)


    Whenever I start my game in VR a weird pattern is drawn over all game graphics. Even thumbnails are affected! To make it disappear I have to restart the editor.

    The pattern looks a lot like the lens distortion UE applied to VR games.

    The preview builds for 4.20 worked just fine, but I can't get VR rendering to work since the official release.

    I can get the pattern to disappear if I take a HighResScreenshot while not in VR. Upon starting the VR mode the pattern reappears though.

    Today I discovered that this only happens when I use DirectX. Vulkan and OpenGL have their own problems though, so I can't really use them. Past version of UE still work - right now I'm using 4.19. I've not found a way to redownload the preview builds.

    Here are the things I've tried:

    * Reinstalling UE 4.20
    * Creating a brand new project
    * Updating my graphics card driver (I'm using an AMD R9 390)
    * Deleting my derived data cache (Which I hope I did correctly)
    * Creating a topic on Answerhub (heh)

    Has anyone else experienced a similar issue? If there's some clean way to reinstall UE, or if anyone has a list of things for me to try, then I'll gladly do it.

    I am completely open to all suggestions. All answers are appreciated!



    #2
    The only idea I have at the moment is that it's somehow related to mixed reality (a new feature in 4.20).

    But mixed reality is part of a plugin which I've not even enabled.

    From what I can see there were no other new VR features in 4.20...

    Comment


      #3
      Removing point lights removes the corruption for all 3D objects. Any ideas? Cause I'm running out.

      Comment


        #4
        Here's the DxDiag.

        Tried rolling back drivers.
        Drivers from last year crash UE4 4.20. Drivers from a few months ago work, but have the same issue.
        So I assume it's not driver related!
        Attached Files

        Comment


          #5
          Is there a better place to get support for problems like these?

          I've tried the Answershub, and I've tried the forums. But I'm hardly getting any views, and basically no responses.

          I feel like this is a technical issue I cannot solve myself. I would appreciate any help.

          Edit: I think my issue's related to the depth buffer. Check this out (Before / After starting VR mode)

          Click image for larger version

Name:	252684depthbufferaftervr.png
Views:	31
Size:	563.3 KB
ID:	1523938

          Comment


            #6
            I have same problem, but to me it only happens if r.screenpercentage is set to exactly 100. Any other number works fine, even 99.9, 100.1 and so on.
            I also have an AMD GPU ( RX480 ), maybe it's related.

            Comment

            Working...
            X