Announcement

Collapse
No announcement yet.

SOLVED: Light Spots on baked light

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    SOLVED: Light Spots on baked light

    Hi everyone. Just updated my scene from 4.15 to 4.20 and when I rebake my light I get a new issue with light spots where there should be none. Anyone know what this could be?

    #2
    Those look like the kinds of artifacts that show up when you decrease lightmass world scale without increasing indirect lighting quality to compensate. Please post your World Settings lightmass values. Also, are you using a modified lightmass.ini file?

    Comment


      #3
      I've attached my lightmass values.
      Last edited by ackehallgren; 08-28-2018, 11:41 AM.

      Comment


        #4
        I really don't know what to do since I haven't changed a thing and it looked fine in 4.15
        Any suggestions?

        Comment


          #5
          You seem to have default light mass settings. Which don't give always give great results.

          My final bake lightmass setting are usually as follows - Please change them to suit your scene

          Static Lighting Level scale - between 0.1 - 0.5 (depending on scene size. Smaller scenes i tend to give a smaller value- large scenes like landscapes I use dynamic lighting global lighting)

          Num indirect lighting bounces = 100 - Probably overkill but after it calculates the 2nd light bounce the other 98 don't really affect bake times

          Skylight bounce - Scene dependant play with the values between 1 -5 are normally good for me

          indirect lighting quality = 6

          Indirect lighting smoothness = 0.6

          Enable use Ambient Occlusion.

          And depending on your scene and what platform you are looking to release your game on untick compress lightmaps - Warning this will take up more memory but reduce artifices.

          Make sure you bake on production quality in your build settings and finally make sure you have a lightmass importance volume

          Comment


            #6
            Thanks a lot! Will try to change these values. I guess the defaults have served me alright so far, so I haven't had a reason to change them.
            Will report back, thanks again!

            Comment


              #7
              Right, so I changed the lightmass settings and it unfortunately only got worse until I found the solution.


              SOLUTION: One of my lamps were intersected with a lightbulb mesh that still casted shadows when it should not have. Embarrassingly easy solution, thanks for the help though!

              Comment

              Working...
              X