Announcement

Collapse
No announcement yet.

Translucent Skysphere

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Translucent Skysphere

    Click image for larger version

Name:	BehindSky.jpg
Views:	19
Size:	36.2 KB
ID:	1516390 How do I get the box in the image that is behind the skysphere to render I've tried changing the translucent priority order setting of both the skysphere and the box but it makes no difference.

    Please help.
    Last edited by Delta1; 08-16-2018, 04:59 PM.

    #2
    I have encountered situations similar to this, and I never found a solution unfortunately .
    Perhaps if you explain your situation a little more, we can think of a workaround.

    I dont know what exactly you are trying to achieve, so its hard for me to give an awnswer. But but here are a couple of ideas which immediatly spring to mind:
    #1 Render the cube into custom depth, and use custom depth as a mask in the skysphere material.
    Or
    #2 Switch the skysphere material to masked mode, and plug a high value into the pixel depth offset in the skysphere material.
    Last edited by somawheels; 08-18-2018, 03:02 PM.

    Comment


      #3
      Originally posted by somawheels View Post
      I have encountered situations similar to this, and I never found a solution unfortunately .
      Perhaps if you explain your situation a little more, we can think of a workaround.

      I dont know what exactly you are trying to achieve, so its hard for me to give an awnswer. But but here are a couple of ideas which immediatly spring to mind:
      #1 Render the cube into custom depth, and use custom depth as a mask in the skysphere material.
      Or
      #2 Switch the skysphere material to masked mode, and plug a high value into the pixel depth offset in the skysphere material.
      I've got a mountain mesh that I need mount in the map so that there's close to no parallax for the player, ie it doesn't change appearance (get noticeably smaller or bigger) from a room that the player is in.

      the room is situated 2km from the mountain and is about 15 m2 but the parallax is pretty bad.

      I've been told that if the mountain is as far away as possible, this should reduce parallax, therefore on the other side of the skysphere might be an option, I dont want to increase the size of the skysphere as it messes with the view, the only other option is to change the cubemap image which would be a shame as the mountains look pretty good.

      Comment


        #4
        Custom depth is the perfect thing for this situation.
        To get custom depth, you need to enable "render custom depth pass" option on the mountain mesh-actor.
        Then, In the skysphere material you can get the custom depth mask using the "sceneTexture" node, and in that node, select "custom depth" option. This will output a mask that is always over the mountain. Divide that mask by a crazy high number like 1000000, and this will give you a mask which you can then multiply with your skysphere opacitymap to to make the mountain appear to always be infornt of the sky.

        Comment


          #5
          Originally posted by somawheels View Post
          Custom depth is the perfect thing for this situation.
          To get custom depth, you need to enable "render custom depth pass" option on the mountain mesh-actor.
          Then, In the skysphere material you can get the custom depth mask using the "sceneTexture" node, and in that node, select "custom depth" option. This will output a mask that is always over the mountain. Divide that mask by a crazy high number like 1000000, and this will give you a mask which you can then multiply with your skysphere opacitymap to to make the mountain appear to always be infornt of the sky.
          Much appreciated I'm going to give this a shot when I'm back on my machine tomorrow!

          Comment


            #6
            Originally posted by somawheels View Post
            Custom depth is the perfect thing for this situation.
            To get custom depth, you need to enable "render custom depth pass" option on the mountain mesh-actor.
            Then, In the skysphere material you can get the custom depth mask using the "sceneTexture" node, and in that node, select "custom depth" option. This will output a mask that is always over the mountain. Divide that mask by a crazy high number like 1000000, and this will give you a mask which you can then multiply with your skysphere opacitymap to to make the mountain appear to always be infornt of the sky.
            Hi SomaWheels,

            When you say skysphere opacity map do you mean the skysphere material, ie setup and plug the nodes in the image to the opacity on the material node of the skysphere material?

            Forgive me I'm an amateur at this.

            Comment


              #7
              saw this in another thread. I still don't understand why you don't simply make the skysphere bigger
              Follow me on Twitter!
              Developer of Elium - Prison Escape
              Local Image-Based Lighting for UE4

              Comment


                #8
                Originally posted by Chosker View Post
                saw this in another thread. I still don't understand why you don't simply make the skysphere bigger
                Because the problem with parallax still exists, the reference mesh is simply made smaller, the main aim is to reduce or remedy parallax completely.

                Comment


                  #9
                  Yes, I mean whatever is plugged into opacity, needs to be multiplied by the custom depth, and the result of that multiplication is then plugged into thge opacity.

                  Comment


                    #10
                    Originally posted by somawheels View Post
                    Yes, I mean whatever is plugged into opacity, needs to be multiplied by the custom depth, and the result of that multiplication is then plugged into thge opacity.
                    thanks again

                    Comment


                      #11
                      Originally posted by somawheels View Post
                      Yes, I mean whatever is plugged into opacity, needs to be multiplied by the custom depth, and the result of that multiplication is then plugged into thge opacity.
                      There's a bit of an issue in that I'm using the standard skysphere so I'm using the default M_sky_panning_clouds material that has nothing plugged to opacity and also nothing to multiply with, when I add the nodes mentioned it does nothing but increase the jaggies around the mountain.

                      I've attached an image of the material node so you know what I've probably messed up, I've currently disconnected the nodes.
                      Attached Files

                      Comment


                        #12
                        That material is not a translucent material. You could change the material mode to translucent, and just plug the custom depth right into translucency.
                        Click image for larger version

Name:	20180821-14_51_02.png
Views:	17
Size:	10.1 KB
ID:	1518346
                        I dont quite understand why you cant just upscale the skysphere either. I have not heard of this problem before.

                        Comment

                        Working...
                        X