Announcement

Collapse
No announcement yet.

Lightmap creates shadow of underlying geometry?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Lightmap creates shadow of underlying geometry?

    Hi,

    Whenever I build my lighting I seem to get a shadow bleeding through to the other side. It's as if Unreal detects nearby geometry and bakes a shadow of it on the opposite side. For instance on a simple wall T-section, the flat wall will show a vertical shadow line where the wall is on the other side. I also have this on a bathtub model where I have a mesh plane behind a hole in the bathtub to seal it off. But on the inside of the bath it should bake nicely. My UV's are clean and lightmap size is also more than enough. It's as if there is a setting causing this that I don't know of? These are production bake screenshots that I posted to visually show what I'm talking about. So it's also not because I'm baking at a lower quality. I tested this in both 4.15 and 4.19, both engines have this issue. I hope it makes sense.



    Thanks in advance!
    Attached Files
    Last edited by WesleyTack; 08-07-2018, 05:33 AM.

    #2
    I have seen this behavior as well before. Maybe try the free GPU lightmass plugin (search in rendering section) ? Its fast and you get nice results.

    Comment


      #3
      Is it definitely lighting? Try turn off post and make sure it's not ambient occlusion, or something to do with distance fields, if you have those enabled.
      Dev Blog
      Twitter: @TheRealSpoonDog
      150 FREE Blueprint functions for your project

      Comment


        #4
        They only occur after I do a lightbake. So it shouldn't be ambient occlusion or distance fields, otherwise I'd see these before the bake as well.

        Comment


          #5
          Hi!

          I would say that your lightmap resolutions are very low: you can see how off/unrealistic they are at the corners: it's even brighter where it should be the darkest, everything is floating... So basically what you see now is a "blurred out", "low res" lighting information which can lead to strange results. I would go higher with those lightmap resolutions and maybe when you have enough detailed lightmaps you'll see proper results.

          Comment


            #6
            I have found out that if I change my "static lighting level scale" to "0.1" inside my world settings it bakes correctly. But changing the entire level scale doesn't seem like the correct solution to this problem, as it's default set to "1". But it works.

            Comment

            Working...
            X