Announcement

Collapse
No announcement yet.

Fortnite grass material

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Fortnite grass material

    How does Fortnight render it's grass so that it blends into the ground texture so well?

    In the image below I have my best attempt on the left and Fortnite on the right. As you can see, Fortnites grass blends really well, but in my attempt the grass billboards are obvious and are not the same color as the ground, even though the textures are the same colors.

    I assume it's a sort of toon shader for the ground and the grass, but I'm having problems working it out?



    #2
    Maybe there is a small fade out at the base of the grass, and the grass color depend on the ground color (I don't remember how to do it, but I know it's possible !)

    Comment


      #3
      Hey Gnimmel, I've been meesing around with something similar with what you are doing.
      This is what I did to solve that problem:



      First of all set the normal to a blue color, then uncheck inside the material properties the "Tangent Space Normal" option.

      Another good idea would be to replace the blue color with the "Object orientation" node, so It will blend well even in not horizontal surfaces:




      This worked for me, I am still adjusting the colors to fully match the grass with the ground but the results are good enough.

      Comment


        #4
        Originally posted by iscaru1988 View Post
        Hey Gnimmel, I've been meesing around with something similar with what you are doing.
        This is what I did to solve that problem:



        First of all set the normal to a blue color, then uncheck inside the material properties the "Tangent Space Normal" option.

        Another good idea would be to replace the blue color with the "Object orientation" node, so It will blend well even in not horizontal surfaces:




        This worked for me, I am still adjusting the colors to fully match the grass with the ground but the results are good enough.
        Your photos are broken!

        Comment


          #5
          He’s correct. The grass will look different because the normal is facing a different direction than the underlying terrain. To compensate for this, most artists will manually adjust the normals of their grass mesh to point upwards. I suggest searching on YouTube, there are a few really good tutorials.

          Or you can use the suggestion mentioned by iscaru1988, that should basically do the same thing.
          Last edited by Nerdsbeware; 07-06-2018, 04:40 PM. Reason: mentioned the wrong person

          Comment


            #6
            Thanks for the replies. I've already improved this a lot by setting the normals in maya to point up.

            iscaru1988, unfortunately your images didn't show up here

            My next tweak is the grass shadow color, it seems darker than the environment.

            Comment


              #7
              try and set the materiel to unlit and see if it work for you

              Comment


                #8
                NerdsBeware is correct.

                vertex "Normals" are the cause.

                vertex normals are what control the light - dark - shade of each polygon. triangle polygons facing the east will catch all the light while the polygon triangle facing the west will catch much less. if you point the normals all "Up" along the Z, then the X-Y directions are canceled out. meaning, both front and back of your grass catch the same light.

                one might imagine you want grass to catch shadow. you want shadow from the tree to blanket the grass, but grass is so thin that, both sides will look the same if they are not hiding under shade coming from another object.

                face east and your grass is bright as hell, face west and its dark as hell.

                long story short. point your normals straight up. blender can edit normals. a blade of grass only has 5 or 10 normals, you can select them all quite easily. just point em up.

                took me a year to track down that solution.
                eventually it hit me one day.

                Comment

                Working...
                X